我们知道默认不同VLAN间数据时不能通信的,想要实现不同VLAN间通信常用的有两种方式:
一、通过三层交换路由功能实现不同VLAN之间的通信
二、通过单臂路由实现不同VLAN之间的通信
1.通过三层SVI虚接口配置路由实现通信:
交换机A的配置
vlan batch 20 30 //创建VLAN20 VLAN30
#
interface Vlanif1
ip address 192.168.1.1 255.255.255.0
#
interface Vlanif20 //创建VLANIF20地址
ip address 192.168.20.1 255.255.255.0
#
interface Vlanif30 //创建VLANIF30地址
ip address 192.168.30.1 255.255.255.0
interface Ethernet0/0/1
port link-type access
port default vlan 20 //划分VLAN20
#
interface Ethernet0/0/2
port link-type access
port default vlan 30 //划分VLAN30
ip route-static 192.168.20.0 255.255.