【模板】快速排序
一、题目描述
利用快速排序算法将读入的 N N N 个数从小到大排序后输出。
快速排序是信息学竞赛的必备算法之一。对于快速排序不是很了解的同学可以自行上网查询相关资料,掌握后独立完成。(C++ 选手请不要试图使用 STL
,虽然你可以使用 sort
一遍过,但是你并没有掌握快速排序算法的精髓。)
二、输入格式
第 1 1 1 行为一个正整数 N N N,第 2 2 2 行包含 N N N 个空格隔开的正整数 a i a_i ai,为你需要进行排序的数,数据保证了 a i a_i ai 不超过 1 0 9 10^9 109。
三、输出格式
将给定的 N N N 个数从小到大输出,数之间空格隔开,行末换行且无空格。
(1)样例输入
5
4 2 4 5 1
(2)样例输出
1 2 4 4 5
四、提示
对于 20 % 20\% 20% 的数据,有 N ≤ 1 0 3 N\leq 10^3 N≤103;
对于 100 % 100\% 100% 的数据,有 N ≤ 1 0 5 N\leq 10^5 N≤105。
五、正确代码
但是没有使用快速排序的模板
import java.util.*;
public class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
int[] a = new int[n];
for (int i = 0; i < n; i++) {
a[i] = sc.nextInt();
}
Arrays.sort(a);
for (int i = 0; i < n; i++) {
System.out.print(a[i] + " ");
}
System.out.println();
}
}
六、使用了快速排序,但显示RE
代码如下:
import java.util.*;
public class Main{
public static void main(String[] args){
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
long[] a = new long[n];
for (int i = 0; i < n; i++) {
a[i] = sc.nextInt();
}
quickSort(a, 0, n - 1);
for (int i = 0; i < n; i++) {
System.out.print(a[i] + " ");
}
System.out.println();
}
public static void quickSort(long[] a, int low, int high) {
int i,j;
long temp,t;
if (low > high){
return;
}
i = low;
j = high;
//temp就是基准位
temp = a[low];
while (i < j){
//先看右边,依次往左递减
while (a[j] >= temp && j > i){
j--;
}
//再看左边,依次往右递增
while (a[i] <= temp && i < j){
i++;
}
//如果满足条件则交换
if (i < j){
t = a[i];
a[i] = a[j];
a[j] = t;
}
}
//最后将基准为与i和j相等位置的数字交换
a[low] = a[i];
a[i] = temp;
//递归调用左半数组
quickSort(a,low,j - 1);
//递归调用右半数组
quickSort(a,j + 1,high);
}
}
伤心,太伤心了
最后和大家分享一下我觉得讲解快速排序很详细的博客,嘿嘿
链接: 快速排序