acwing.滑动窗口https://www.acwing.com/problem/content/156/
给定一个大小为 n≤106≤106 的数组。
有一个大小为 k 的滑动窗口,它从数组的最左边移动到最右边。
你只能在窗口中看到 k 个数字。
每次滑动窗口向右移动一个位置。
以下是一个例子:
该数组为 [1 3 -1 -3 5 3 6 7]
,k 为 33。
窗口位置 | 最小值 | 最大值 |
---|---|---|
[1 3 -1] -3 5 3 6 7 | -1 | 3 |
1 [3 -1 -3] 5 3 6 7 | -3 | 3 |
1 3 [-1 -3 5] 3 6 7 | -3 | 5 |
1 3 -1 [-3 5 3] 6 7 | -3 | 5 |
1 3 -1 -3 [5 3 6] 7 | 3 | 6 |
1 3 -1 -3 5 [3 6 7] | 3 | 7 |
你的任务是确定滑动窗口位于每个位置时,窗口中的最大值和最小值。
输入格式
输入包含两行。
第一行包含两个整数 n 和 k,分别代表数组长度和滑动窗口的长度。
第二行有 n 个整数,代表数组的具体数值。
同行数据之间用空格隔开。
输出格式
输出包含两个。
第一行输出,从左至右,每个位置滑动窗口中的最小值。
第二行输出,从左至右,每个位置滑动窗口中的最大值。
输入样例:
8 3
1 3 -1 -3 5 3 6 7
输出样例:
-1 -3 -3 -3 3 3
3 3 5 5 6 7
代码及注释:
// Problem: 滑动窗口
// Contest: AcWing
// URL: https://www.acwing.com/problem/content/156/
// Memory Limit: 64 MB
// Time Limit: 1000 ms
//
// Powered by CP Editor (https://cpeditor.org)
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long LL;
const int N = 2000010;
int a[N],q[N];
int n,k;
int main(){
cin>>n>>k;
for(int i=0;i<n;i++){
cin>>a[i];
}
//找最小值
int hh=0,tt=-1;
for(int i=0;i<n;i++){
if(hh<=tt&&i-q[hh]+1>k){ //保证窗口不包括这个元素了
hh++;
}
while(hh<=tt&&a[q[tt]]>=a[i]){ //如果要进队的下一个数小于队尾,那么队尾出队,下一步加上新来的数
tt--;
}
q[++tt]=i;
if(i>=k-1){ //下标从0开始,i>窗口后,当队头元素在窗口的左边的时候,弹出队头,由于1,3的时候i还没不满足滑动窗口,所以只能先输出-1
cout<<a[q[hh]]<<' ';
}
}
puts("");
hh=0,tt=-1;
for(int i=0;i<n;i++){
if(hh<=tt&&i-q[hh]+1>k){
hh++;
}
while(hh<=tt&&a[q[tt]]<=a[i]){
tt--;
}
q[++tt]=i;
if(i>=k-1){
cout<<a[q[hh]]<<' ';
}
}
puts("");
return 0;
}