给定每个人的家庭成员和其自己名下的房产,请你统计出每个家庭的人口数、人均房产面积及房产套数。
输入格式:
输入第一行给出一个正整数N(≤1000),随后N行,每行按下列格式给出一个人的房产:
编号 父 母 k 孩子1 ... 孩子k 房产套数 总面积
其中编号是每个人独有的一个4位数的编号;父和母分别是该编号对应的这个人的父母的编号(如果已经过世,则显示-1);k(0≤k≤5)是该人的子女的个数;孩子i是其子女的编号。
输出格式:
首先在第一行输出家庭个数(所有有亲属关系的人都属于同一个家庭)。随后按下列格式输出每个家庭的信息:
家庭成员的最小编号 家庭人口数 人均房产套数 人均房产面积
其中人均值要求保留小数点后3位。家庭信息首先按人均面积降序输出,若有并列,则按成员编号的升序输出。
输入样例:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100输出样例:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
#include <iostream>
#include <map>
#include <vector>
#include <algorithm>
using namespace std;
map<int, int> anc; //编号->祖先
map< int, pair<int, int> > infor; //编号->房产套数,总面积
class Family
{
public:
int num; //家庭成员最小编号
int count; //家庭人口数
double house; //人均房产套数
double size; //人均房产面积
int zuxian; //(最高)祖先
void init(int n)
{
num = n;
count = 1;
house = infor[n].first;
size = infor[n].second;
zuxian = anc[n];
return;
}
};
int findd(int n) //查找n的(最高)祖先
{
if (anc[n] == n)
return n;
anc[n] = findd(anc[n]);
return anc[n];
}
void unionn(int a, int b) //合并a与b(建立共同祖先)
{
if (a == -1 || b == -1)
return;
int a_anc = findd(a);
int b_anc = findd(b);
anc[a_anc] = b_anc;
return;
}
bool cmp(pair<int, int> a, pair<int, int> b)
{
if (a.second == b.second)
return a.first < b.first;
return a.second < b.second;
}
bool cmp2(Family a, Family b)
{
if (a.size != b.size)
return a.size > b.size;
return a.num < b.num;
}
int main()
{
int n; cin >> n;
for (int i = 0; i < n; i++) {
int pe, fa, mo; cin >> pe >> fa >> mo;
anc.insert(make_pair(pe, pe));
if (fa != -1)
anc.insert(make_pair(fa, fa));
if (mo != -1)
anc.insert(make_pair(mo, mo));
//建立pe与fa、mo的联系
unionn(pe, fa); unionn(pe, mo);
int k; cin >> k;
for (int j = 0; j < k; j++) {
int chi; cin >> chi;
anc.insert(make_pair(chi, chi));
//建立pe与各个chi的联系
unionn(pe, chi);
}
int a, b; cin >> a >> b;
infor.insert(make_pair(pe, make_pair(a, b)));
}
for (map<int, int>::iterator it = anc.begin(); it != anc.end(); it++)
findd((*it).first); //更新所有人的祖先编号
vector< pair<int, int> > ancestor;
ancestor.assign(anc.begin(), anc.end()); //拷贝祖先数据,准备排序:祖先升序->编号升序
sort(ancestor.begin(), ancestor.end(), cmp);
vector<Family> res;
Family family; family.init(ancestor[0].first); //创建家庭,并统计数据
for (int i = 1; i < ancestor.size(); i++) {
if (ancestor[i].second == family.zuxian) { //同一家庭,数据叠加
family.count++;
family.house += infor[ancestor[i].first].first;
family.size += infor[ancestor[i].first].second;
}
else { //新家庭,结算上一家庭数据
family.house /= family.count;
family.size /= family.count;
res.push_back(family);
family.init(ancestor[i].first);
}
//最后一次直接结算
if (i == ancestor.size() - 1) {
family.house /= family.count;
family.size /= family.count;
res.push_back(family);
family.init(ancestor[i].first);
}
}
cout << res.size() << endl;
sort(res.begin(), res.end(), cmp2); //排序:人均面积降序->编号升序
for (int i = 0; i < res.size(); i++) {
printf("%04d %d %.3f %.3f\n", res[i].num, res[i].count, res[i].house, res[i].size);
}
return 0;
}
注意事项:
题目给的数据比较多,使用并查集寻找共同祖先。
如有问题,欢迎提出。