以上图片来自新浪微博。
本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:
- 无论用户说什么,首先把对方说的话在一行中原样打印出来;
- 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
- 把原文中所有大写英文字母变成小写,除了
I
; - 把原文中所有独立的
can you
、could you
对应地换成I can
、I could
—— 这里“独立”是指被空格或标点符号分隔开的单词; - 把原文中所有独立的
I
和me
换成you
; - 把原文中所有的问号
?
换成惊叹号!
; - 在一行中输出替换后的句子作为 AI 的回答。
输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。
输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI:
和一个空格。
输入样例:
6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know
输出样例:
Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know
//这大抵是我至今遇到的20分题中最难的一个,题意就是把规则部分实现,都是些对字符串的处理,有点要求太多了,纵观网络上的解法,要么代码长,要么不易理解,下面给出两份不错的代码,大家予以参考。
L1-064 估值一亿的AI核心代码 (20分)_wmy0217_的博客-CSDN博客
#include<bits/stdc++.h>
using namespace std;
int main(){
int n;
string s;
cin>>n;
getchar();
while(getline(cin,s)){
cout<<s<<endl<<"AI: ";
s=regex_replace(s,regex(R"(\s+)")," ");
s=regex_replace(s,regex(R"(^\s+|\s+$|\s+(?=\W))"),"");
s=regex_replace(s,regex(R"(\bI\b)"),"mark_mark");
for(int i=0;i<s.size();i++)
if(s[i]!='I')s[i]=tolower(s[i]);
s=regex_replace(s,regex(R"(\bcan you\b)"),"I can");
s=regex_replace(s,regex(R"(\bcould you\b)"),"I could");
s=regex_replace(s,regex(R"(mark_mark|\bme\b)"),"you");
s=regex_replace(s,regex(R"(\?)"),"!");
cout<<s<<endl;
}
return 0;
}