1008 Elevator
分数 20
作者 CHEN, Yue
单位 浙江大学
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.
Output Specification:
For each test case, print the total time on a single line.
Sample Input:
3 2 3 1
Sample Output:
41
所需变量
int N;//代表需要在多少个楼层停靠
int a[100];//代表每次所需要停靠的楼层
int sum;//代表需要多少时间
思路:我们首先获取N,然后输入N个数,然后再进行判断他是上楼还是下楼,然后再决定所需要的秒数。
代码如下(编译器是dev,语言是C++):
#include<iostream>
using namespace std;
int N,a[100],sum = 0;
int main(){
cin>>N;
for(int i = 0;i<N;i++){
cin>>a[i];
if(i == 0){
sum += 6*a[i] + 5;
}else{
if(a[i]>a[i-1]){
sum += (a[i]-a[i-1])*6 + 5;
}else if(a[i] == a[i-1]){
sum += 5;
}else{
sum += (a[i-1]-a[i])*4 + 5;
}
}
}
printf("%d\n",sum);
return 0;
}