HCIA-经典综合实验(二)

news2024/11/18 3:25:47

经典综合实验(二)

  • 实验拓扑
  • 配置步骤
    • 配置Eth-Trunk聚合链路
    • 第一步 配置二层VLAN
    • 第二步 配置MSTP生成树
    • 第三步 配置相关IP地址
    • 第四步 配置DHCP及DHCP中继
    • 第五步 配置三层的网关冗余协议 VRRP及OSPF
    • 第六步 配置静态路由,NAT地址转换及其他配置完善
  • 配置验证
    • 确保内网设备都可以访问到外网
    • 确保VLAN10的数据走SW1 VLAN20的数据走SW2
    • Client1和Client2都可以通过域名访问WEB服务器
    • 抓包查看外网是否是通过地址池中配置的地址进行上网的

实验拓扑

在这里插入图片描述

配置步骤

配置Eth-Trunk聚合链路

SW1

sysname SW1
#
undo info-center enable  //关闭交换机日志信息
#
lldp enable  //做邻居发现的,可以看到自己的端口和对端设备的端口
#
interface Eth-Trunk1
 mode lacp-static
#
interface Eth-Trunk2
 mode lacp-static
#
interface GigabitEthernet0/0/3
 eth-trunk 1
#
interface GigabitEthernet0/0/4
 eth-trunk 1
#
interface GigabitEthernet0/0/23
 eth-trunk 2
#
interface GigabitEthernet0/0/24
 eth-trunk 2
  • 查看相应的邻居列表
  • [SW1]dis lldp neighbor brief

SW2

sysname SW2
#
undo info-center enable 
#
lldp enable 
#
interface Eth-Trunk1
 mode lacp-static
#
interface Eth-Trunk3
 mode lacp-static
#
interface GigabitEthernet0/0/3
 eth-trunk 1
#
interface GigabitEthernet0/0/4
 eth-trunk 1
#
interface GigabitEthernet0/0/23
 eth-trunk 3
#
interface GigabitEthernet0/0/24
 eth-trunk 3

SW3

sysname SW3
#
undo info-center enable
#
lldp enable
#
interface Eth-Trunk2
 mode lacp-static
#
interface Eth-Trunk3
 mode lacp-static
#
interface GigabitEthernet0/0/1
 eth-trunk 2
#
interface GigabitEthernet0/0/2
 eth-trunk 2
#
interface GigabitEthernet0/0/22
 eth-trunk 3
#
interface GigabitEthernet0/0/23
 eth-trunk 3

第一步 配置二层VLAN

SW1

vlan batch 10 20 100
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Eth-Trunk2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 100

SW2

vlan batch 10 20 200
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Eth-Trunk3
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 200

SW3

vlan batch 10 20
#
interface Eth-Trunk2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Eth-Trunk3
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/10
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/24
 port link-type access
 port default vlan 20

第二步 配置MSTP生成树

SW1

stp mode mstp  // 华为交换机默认是 MSTP,所以这条命令可写可不写
#
stp region-configuration
 region-name wml
 instance 1 vlan 10
 instance 2 vlan 20
 active region-configuration
#
stp instance 1 root primary
stp instance 2 root secondary

SW2

stp region-configuration
 region-name wml
 instance 1 vlan 10
 instance 2 vlan 20
 active region-configuration
#
stp instance 1 root secondary
stp instance 2 root primary

SW3

stp region-configuration
 region-name wml
 instance 1 vlan 10
 instance 2 vlan 20
 active region-configuration
#
stp edged-port default   //设置此交换机所有接口为边缘端口
stp bpdu-protection  //配置BPDU保护
#
interface Eth-Trunk2
 stp edged-port disable   //关闭此接口的边缘端口
#
interface Eth-Trunk3
 stp edged-port disable   //关闭此接口的边缘端口

[SW1]dis stp brief 查看STP的选举情况
在这里插入图片描述
在这里插入图片描述

第三步 配置相关IP地址

SW1

interface Vlanif10
 ip address 172.16.10.253 255.255.255.0
 #
interface Vlanif20
 ip address 172.16.20.252 255.255.255.0
 #
interface Vlanif100
 ip address 172.16.100.1 255.255.255.248

SW2

interface Vlanif10
 ip address 172.16.10.252 255.255.255.0
 #
interface Vlanif20
 ip address 172.16.20.253 255.255.255.0
 #
interface Vlanif200
 ip address 172.16.200.1 255.255.255.248

R1

sysname R1
#
interface GigabitEthernet0/0/0
 ip address 10.0.0.1 255.255.255.248 
#
interface GigabitEthernet0/0/1
 ip address 172.16.100.2 255.255.255.248 

R2

sysname R2
#
interface GigabitEthernet0/0/0
 ip address 10.0.1.1 255.255.255.248 
#
interface GigabitEthernet0/0/1
 ip address 172.16.200.2 255.255.255.248 

FW3

sysname USG6000V1
#
interface GigabitEthernet0/0/0
 undo shutdown
 ip address 192.168.0.1 255.255.255.0
 #
interface GigabitEthernet1/0/0
 undo shutdown
 ip address 10.0.1.2 255.255.255.248
#
interface GigabitEthernet1/0/1
 undo shutdown
 ip address 202.2.2.1 255.255.255.252
#
interface GigabitEthernet1/0/2
 undo shutdown
 ip address 10.1.10.254 255.255.255.0
#
interface GigabitEthernet1/0/3
 undo shutdown
 ip address 10.1.20.254 255.255.255.0
#
interface GigabitEthernet1/0/4
 undo shutdown
 ip address 10.0.0.2 255.255.255.248
 service-manage ping permit    //允许ping

ISP

sysname ISP
#
interface GigabitEthernet0/0/0
 ip address 202.2.2.2 255.255.255.252 
#
interface GigabitEthernet0/0/1
 ip address 3.3.3.254 255.255.255.0 
#
interface LoopBack0
 ip address 114.114.114.114 255.255.255.255 

第四步 配置DHCP及DHCP中继

SW1

dhcp enable
#
interface Vlanif10
 dhcp select relay
 dhcp relay server-ip 172.16.100.2
#
interface Vlanif20
 dhcp select relay
 dhcp relay server-ip 172.16.100.2

SW2

dhcp enable
#
interface Vlanif10
 dhcp select relay
 dhcp relay server-ip 172.16.200.2
#
interface Vlanif20
 dhcp select relay
 dhcp relay server-ip 172.16.200.2

R1

dhcp enable
#
ip pool vlan10
 gateway-list 172.16.10.254 
 network 172.16.10.0 mask 255.255.255.0 
 excluded-ip-address 172.16.10.240 172.16.10.253 
 dns-list 202.2.2.222 
#
ip pool vlan20
 gateway-list 172.16.20.254 
 network 172.16.20.0 mask 255.255.255.0 
 excluded-ip-address 172.16.20.240 172.16.20.253 
 dns-list 202.2.2.222 
#
interface GigabitEthernet0/0/1
 dhcp select global

R2

dhcp enable
#
ip pool vlan10
 gateway-list 172.16.10.254 
 network 172.16.10.0 mask 255.255.255.0 
 excluded-ip-address 172.16.10.240 172.16.10.253 
 dns-list 202.2.2.222 
#
ip pool vlan20
 gateway-list 172.16.20.254 
 network 172.16.20.0 mask 255.255.255.0 
 excluded-ip-address 172.16.20.240 172.16.20.253 
 dns-list 202.2.2.222 
#
interface GigabitEthernet0/0/1
 dhcp select global

第五步 配置三层的网关冗余协议 VRRP及OSPF

SW1

interface Vlanif10
 vrrp vrid 2 virtual-ip 172.16.10.254
 vrrp vrid 2 priority 150
 vrrp vrid 2 track interface Eth-Trunk2 reduced 100
 vrrp vrid 2 track interface GigabitEthernet0/0/1 reduced 100
#
interface Vlanif20
 vrrp vrid 1 virtual-ip 172.16.20.254
#
ospf 1 router-id 11.11.11.11
 silent-interface all
 undo silent-interface Vlanif100
 area 0.0.0.0
  network 172.16.10.0 0.0.0.255
  network 172.16.20.0 0.0.0.255
  network 172.16.100.1 0.0.0.0

SW2

interface Vlanif10
 vrrp vrid 2 virtual-ip 172.16.10.254
#
interface Vlanif20
 vrrp vrid 1 virtual-ip 172.16.20.254
 vrrp vrid 1 priority 150
 vrrp vrid 1 track interface Eth-Trunk3 reduced 100
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 100
#
ospf 1 router-id 22.22.22.22
 silent-interface all
 undo silent-interface Vlanif200
 area 0.0.0.0
  network 172.16.10.0 0.0.0.255
  network 172.16.20.0 0.0.0.255
  network 172.16.200.1 0.0.0.0

[SW1]display vrrp brief 查看VRRP主备情况
确保SW1的接口断开后VRRP可以自动切换到SW2上
在这里插入图片描述
在这里插入图片描述

在这里插入图片描述

R1

ospf 1 router-id 1.1.1.1 
 default-route-advertise
 area 0.0.0.0 
  network 10.0.0.1 0.0.0.0 
  network 172.16.100.2 0.0.0.0 

R2

ospf 1 router-id 2.2.2.2 
 default-route-advertise
 area 0.0.0.0 
  network 10.0.1.1 0.0.0.0 
  network 172.16.200.2 0.0.0.0 

FW3

ospf 1 router-id 3.3.3.3
 default-route-advertise
 area 0.0.0.0
  network 10.0.0.2 0.0.0.0
  network 10.0.1.2 0.0.0.0
  network 10.1.10.0 0.0.0.0
  network 10.1.10.0 0.0.0.255
  network 10.1.20.0 0.0.0.0
  network 10.1.20.0 0.0.0.255

第六步 配置静态路由,NAT地址转换及其他配置完善

FW3

firewall zone trust   //把接口划入到trust区域,安全区域,一般用于内部网络
 set priority 85
 add interface GigabitEthernet0/0/0
 add interface GigabitEthernet1/0/0
 add interface GigabitEthernet1/0/4
#
firewall zone untrust  //把接口划入到untrust区域,非安全区域,一般用于网络出口
 set priority 5
 add interface GigabitEthernet1/0/1
#
firewall zone dmz  //把接口划入到DMZ区域,服务器区域,一般用于服务器接口下
 set priority 50
 add interface GigabitEthernet1/0/2
 add interface GigabitEthernet1/0/3
#
ip route-static 0.0.0.0 0.0.0.0 202.2.2.2  //配置上网的默认路由
ip route-static 202.2.2.220 255.255.255.255 NULL0     //防止路由环路,配置NULL0路由
ip route-static 202.2.2.221 255.255.255.255 NULL0
ip route-static 202.2.2.222 255.255.255.255 NULL0
ip route-static 202.2.2.223 255.255.255.255 NULL0
#
//配置内外网映射
 nat server 0 protocol udp global 202.2.2.222 dns inside 10.1.10.220 dns
 nat server 1 protocol tcp global 202.2.2.223 www inside 10.1.20.220 www
#
//规划NAT地址池
nat address-group trust 0
 mode pat
 section 0 202.2.2.220 202.2.2.221
#
//配置各种安全策略
security-policy
 rule name P1   //规则名称
  source-zone local    //源区域
  action permit   //动作允许
 rule name P2   //规则名称
  source-zone trust    //源区域
  destination-zone dmz   //目的区域
  destination-zone untrust
  action permit   //动作允许
 rule name P3
  source-zone untrust
  destination-zone dmz
  action permit
#
//配置NAT策略
nat-policy
 rule name NAT1
  source-zone trust
  destination-zone untrust
  action source-nat address-group trust

ISP

//用户向运营商购买IP地址后,ISP需要配置静态路由指向用户的网关
ip route-static 202.2.2.220 255.255.255.255 202.2.2.1
ip route-static 202.2.2.221 255.255.255.255 202.2.2.1
ip route-static 202.2.2.222 255.255.255.255 202.2.2.1
ip route-static 202.2.2.223 255.255.255.255 202.2.2.1

配置验证

确保内网设备都可以访问到外网

在这里插入图片描述
其余自行测试

确保VLAN10的数据走SW1 VLAN20的数据走SW2

在这里插入图片描述
在这里插入图片描述

Client1和Client2都可以通过域名访问WEB服务器

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

抓包查看外网是否是通过地址池中配置的地址进行上网的

在这里插入图片描述

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.coloradmin.cn/o/1211131.html

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈,一经查实,立即删除!

相关文章

【Regulatory Genomics】Part2 BPNet、DeepLIFT

文章目录 Deep learning at base-resolution reveals cis-regulatory motif syntaxproblemBPNet: predicting base-resolution profiles from DNA sequenceInterpreting the predictions of BPNet1 DeepLIFT2 TF-MoDISCO3 motif syntax derived TF cooperativity Experimental …

Visual Studio Code安装和设置中文

文章目录 Visual Studio Code安装Visual Studio Code设置中文 步骤如下: Visual Studio Code安装 1.下载安装包 VS Code的官网 下载链接中的“az764295.vo.msecnd.net” 替换为国内镜像地址“vscode.cdn.azure.cn”,下载速度直接飙升至几十 Mb/s。(在官网下载速度…

Elasticsearch 之聚合分析

本文主要介绍 Elasticsearch 的聚合功能,介绍什么是 Bucket 和 Metric 聚合,以及如何实现嵌套的聚合。 首先来看下聚合(Aggregation): 1 什么是 Aggregation? 首先举一个生活中的例子,这个是京…

【Python】一文带你掌握数据容器之集合,字典

目录: 一、集合 思考:我们目前接触到了列表、元组、字符串三个数据容器了。基本满足大多数的使用场景为何又需要学习新的集合类型呢? 通过特性来分析: (1)列表可修改、支持重复元素且有序 (2)元组、字符…

解决k8s通过traefik暴露域名失败并报错:Connection Refused的问题

我敢说本篇文章是网上为数不多的解决traefik暴露域名失败问题的正确文章。 我看了网上太多讲述traefik夸夸其谈的文章了,包含一大堆复制粘贴的水文和还有什么所谓“阿里技术专家”的文章,讲的全都是错的!基本没有一个能说到点子上去&#xf…

用LLM生成反驳:首先洞察审稿人的心理,再巧妙回应!

深度学习自然语言处理 原创作者:Winnie 在科研领域,同行评审(review-rebuttal)是保证学术质量的关键环节。这一过程中的辩论和反驳非常具有挑战性。传统的同行评审生成任务通常集中在表面层面的推理。 研究人员发现,考虑论点背后的态度根源和…

aliyun Rest ful api V3版本身份验证构造

aliyun Rest ful api V3版本身份验证构造 参考官网:https://help.aliyun.com/zh/sdk/product-overview/v3-request-structure-and-signature?spma2c4g.11186623.0.0.787951e7lHcjZb 构造代码 :使用GET请求进行构造,算法使用sha256 使用postm…

多维时序 | MATLAB实现PSO-BiLSTM-Attention粒子群优化双向长短期记忆神经网络融合注意力机制的多变量时间序列预测

多维时序 | MATLAB实现PSO-BiLSTM-Attention粒子群优化双向长短期记忆神经网络融合注意力机制的多变量时间序列预测 目录 多维时序 | MATLAB实现PSO-BiLSTM-Attention粒子群优化双向长短期记忆神经网络融合注意力机制的多变量时间序列预测预测效果基本介绍模型描述程序设计参考…

Python安装第三方库出错完美解决方法

错误 Could not find a version that satisfies the requirement PIL (from versions: none) ERROR: No matching distribution found for PILTry to run this command from the system terminal. Make sure that you use the correct version of pip installed for your Pyth…

Linux:给openlab搭建web网站

httpd服务器建立综合练习 建立网站需求: 1.基于域名 www.openlab.com 可以访问网站内容为 welcome to openlab!!! 2.给该公司创建三个子界面分别显示学生信息,教学资料和缴费网站, (1)、基于 www.openlab.com/stud…

使用Pandas进行数据读写的简易教程

Pandas是一个功能强大且广泛使用的Python库。它提供了一种简单而灵活的方式来读取和写入各种数据格式,包括CSV、Excel、SQL数据库等。本文将介绍如何使用Pandas进行数据的读取和写入操作,帮助你快速上手并高效地处理数据。 一、安装和导入pandas 首先&…

Linux软硬链接

文章目录 🐋1. 建立软硬链接现象🐠2. 软硬链接🪸2.1 软链接🪸2.2 硬链接 🐦3. 应用场景🪹3.1 软链接应用场景🪹3.2 硬链接应用场景 🐋1. 建立软硬链接现象 我们这里给file.txt建立软…

CH12_处理继承关系

函数上移(Pull Up Method) 反向重构:函数下移(Push Down Method) class Employee {/*...*/} class Salesman extends Employee {get name() {/*...*/} } class Engineer extends Employee {get name() {/*...*/} }cla…

AI数字员工创新工作模式丨市女协走进实在智能,沉浸体验RPA Agent智能魅力

11月10日,杭州市女企业家协会组织走进副会长张军燕企业——杭州实在智能科技有限公司,开展“领跑AI时代,做先进企业”人工智能沙龙活动。 本次沙龙是一场真正关注最前沿AI大模型与RPA自动化技术、寻找企业确定性增长的科技盛宴,也…

《深入浅出.NET框架设计与实现》阅读笔记(四)

静态文件系统 通过ASP.NET Core 提供的静态文件模块和静态文件中间件,可以轻松的让应用程序拥有访问静态文件的功能,同时可以基于IFileProvider对象来自定义文件系统,如基于Redis做扩展文件系统 启动静态文件服务 在Program.cs 类中&#x…

Fedora Linux 39 正式版官宣 11 月 发布

导读Fedora Linux 39 正式版此前宣布将于 10 月底发布,不过这款 Linux 发行版面临了一些延期,今天开发团队声称,Fedora Linux 39 正式版将于 11 月 7 日发布。 过查询得知,在近日的 "Go / No-Go" 会议上,开…

国产企业级低代码开发哪个最好?这一款超好用

低代码开发平台(Low-code Development Platform)正在迅速崛起,成为未来软件技术发展的主导趋势。通过使用低代码开发平台,企业能够显著提高开发效率,降低对专业开发人员的依赖,并实现更快速的软件交付和使用…

【从删库到跑路】MySQL数据库 | 全局锁 | 表级锁 | 行级锁

文章目录 🌹简述🎄全局锁⭐数据备份🎈设置全局锁🎈对表进行备份🎈释放锁 🎄表级锁🛸表锁⭐读锁⭐写锁 🛸元数据锁🛸意向锁⭐意向共享锁⭐意向排他锁 🎄行级锁…

某头部通信企业:SDLC+模糊测试,保障数实融合安全发展

某头部通信企业是全球领先的综合通信信息解决方案提供商,为全球电信运营商、政企客户和消费者提供创新的技术与产品解决方案。该企业持续关注核心技术攻关,深入打造系列化标杆项目和价值场景,加强数字化平台的推广应用,加快共建开…