Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
#include<iostream>
using namespace std;
const int maxn = 10010;
int a[maxn], b[maxn];
int dp[maxn];
int main(){
int n;
cin >> n;
bool flag = false;
for (int i = 0; i < n; i++) {
cin >> a[i];
if (a[i] >= 0)
flag = true;
}
if (flag == false) {
cout << 0 << " " << a[0] << " "<< a[n - 1] <<endl;
return 0;
}
dp[0] = a[0];
b[0] = 0;
for (int i = 1; i < n; i++) {
if (dp[i - 1] >= 0) {
dp[i] = dp[i - 1] + a[i];
b[i] = b[i - 1];
}
else{
dp[i] = a[i];
b[i] = i;
}
}
int k = 0;
for (int i = 0; i < n; i++) {
if (dp[i] > dp[k])
k = i;
}
cout << dp[k] << " " << a[b[k]] << " " << a[k] << endl;
return 0;
}
本题思路:
用数组a来保存输入的序列,b【i】表示以啊【i】作为结尾的最大连续子序列是从哪个元素开始的(记录下标),dp【i】表示以a【i】作为结尾元素的最大连续子序列和,只有两种情况,第一种:连续序列只有一个元素,即a【i】(a【i】<0时),第二种情况,dp【i-1】+a【i】(a【i】>=0时)。
拓展:
#include<iostream>
using namespace std;
const int maxn = 10010;
int a[maxn], b[maxn][2];
int dp[maxn];
int main(){
int n;
cin >> n;
for (int i = 0; i < n; i++) {
cin >> a[i];
}
dp[0] = a[0];
b[0][0] = 0, b[0][1] = 0;
for (int i = 1; i < n; i++) {
if (dp[i - 1] >= 0) {
dp[i] = dp[i - 1] + a[i];
b[i][0] = b[i - 1][0];
b[i][1] = i;
}
else{
dp[i] = a[i];
b[i][0] = i;
b[i][1] = i;
}
}
int k = 0;
for (int i = 0; i < n; i++) {
if (dp[i] > dp[k])
k = i;
}
cout << dp[k] << " " << b[k][0]<< " " << b[k][1]<< endl;
return 0;
}
这是求最大子序列的开始和结束下标(从0开始)。