题目描述
输入 个正整数 ,按照从大到小的顺序输出不重复的数。
输入格式
第一行一个整数 n 。
第二行 个用空格隔开的正整数 。
输出格式
每行一个正整数,为从大到小排序后的不重复的数。
样例 #1
样例输入 #1
8 1 3 4 2 2 2 3 1
样例输出 #1
4 3 2 1
提示
对于 50% 的数据:1≤100001≤n≤10000 。
对于 100% 的数据:1≤2×1051≤n≤2×105,−109≤109−109≤≤109。
代码
#include <bits/stdc++.h>
using namespace std;
set<int,greater<int> > s;
set<int>::iterator it;
int n;
int main(){
cin>>n;
for(int i=1;i<=n;i++){
int x;
cin>>x;
s.insert(x);
}
for(auto it=s.begin();it!=s.end();it++){
cout<<*it<<'\n';
}
return 0;
}