帧中继多点子接口配置
拓扑图:
设备参数:
设备 | 接口 | DLCI | 设备 | 接口 | DLCI |
R1 | S0/0/0 | 102 | R2 | S0/0/0 | 201 |
R1 | S0/0/0 | 103 | R3 | S0/0/0 | 301 |
IP参数:
设备 | 接口 | IP地址 | 子网掩码 | 默认网关 |
R1 | S0/0/0.1 | 192.168.123.1 | 255.255.255.0 | N/A |
R2 | S0/0/0.1 | 192.168.123.2 | 255.255.255.0 | N/A |
R3 | S0/0/0。1 | 192.168.123.2 | 255.255.255.0 | N/A |
实验过程:
FRSwitch配置:
R1步骤:
Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface s0/0/0
R1(config-if)#no ip address
R1(config-if)#encapsulation frame-relay
R1(config-if)#no frame-relay inverse-arp
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R1(config-if)#interface s0/0/0.1 mu
R1(config-if)#interface s0/0/0.1 multipoint
R1(config-subif)#
%LINK-5-CHANGED: Interface Serial0/0/0.1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.1, changed state to up
R1(config-subif)#ip address 192.168.123.1 255.255.255.0
R1(config-subif)#frame-relay map ip 192.168.123.2 102 broadcast
R1(config-subif)#frame-relay map ip 192.168.123.3 103 broadcast
R1(config-subif)#frame-relay map ip 192.168.123.1 102
R1(config-subif)#no frame-relay inverse-arp
R1(config-subif)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#show frame-relay map
Serial0/0/0.1 (up): ip 192.168.123.2 dlci 102, static,
broadcast,
CISCO, status defined, active
Serial0/0/0.1 (up): ip 192.168.123.3 dlci 103, static,
broadcast,
CISCO, status defined, active
Serial0/0/0.1 (up): ip 192.168.123.1 dlci 102, static,
CISCO, status defined, active
R1#ping 192.168.123.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 33/44/53 ms
R1#ping 192.168.123.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 13/22/26 ms
R1#ping 192.168.123.3
R2步骤:
Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface s0/0/0
R2(config-if)#no ip address
R2(config-if)#encapsulation frame-relay
R2(config-if)#no frame-relay inverse-arp
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#interface s0/0/0.1 multipoint
R2(config-subif)#
%LINK-5-CHANGED: Interface Serial0/0/0.1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.1, changed state to up
R2(config-subif)#ip address 192.168.123.2 255.255.255.0
R2(config-subif)#frame-relay map ip 192.168.123.1 201 broadcast
R2(config-subif)#frame-relay map ip 192.168.123.3 201 broadcast
R2(config-subif)#frame-relay map ip 192.168.123.2 201
interface-dlci Define a DLCI on an interface/subinterface
map Map a protocol address to a DLCI address
R2(config-subif)#no frame-relay inverse-arp
R2(config-subif)#end
R2#
%SYS-5-CONFIG_I: Configured from console by console
R2#show frame-relay map
Serial0/0/0.1 (up): ip 192.168.123.1 dlci 201, static,
broadcast,
CISCO, status defined, active
Serial0/0/0.1 (up): ip 192.168.123.3 dlci 201, static,
broadcast,
CISCO, status defined, active
Serial0/0/0.1 (up): ip 192.168.123.2 dlci 201, static,
CISCO, status defined, active
R2#ping 192.168.123.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 33/39/47 ms
R2#ping 192.168.123.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 15/21/28 ms
R2#ping 192.168.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 34/42/57 ms
R3配置:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#interface s0/0/0
R3(config-if)#no ip address
R3(config-if)#encapsulation frame-relay
R3(config-if)#no sh
R3(config-if)#no frame-relay inverse-arp
R3(config-if)#no shutdown
R3(config-if)#interface s0/0/0.1 multipoint
R3(config-subif)#ip address 192.168.123.3 255.255.255.0
R3(config-subif)#frame-relay map ip 192.168.123.1 301 broadcast
R3(config-subif)#frame-relay map ip 192.168.123.2 301 broadcast
R3(config-subif)#frame-relay map ip 192.168.123.3 301
R3(config-subif)#no frame-relay inverse-arp
% Invalid input detected at '^' marker.
R3(config-subif)#end
R3#
%SYS-5-CONFIG_I: Configured from console by console
R3#show frame-relay map
Serial0/0/0.1 (down): ip 192.168.123.1 dlci 301, static,
broadcast,
CISCO, status defined, inactive
Serial0/0/0.1 (down): ip 192.168.123.2 dlci 301, static,
broadcast,
CISCO, status defined, inactive
Serial0/0/0.1 (down): ip 192.168.123.3 dlci 301, static,
CISCO, status defined, inactive
R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINK-5-CHANGED: Interface Serial0/0/0.1, changed state to up
R3(config-if)#end
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0.1, changed state to up
R3#
%SYS-5-CONFIG_I: Configured from console by console
R3#show frame-relay map
Serial0/0/0.1 (up): ip 192.168.123.1 dlci 301, static,
broadcast,
CISCO, status defined, active
Serial0/0/0.1 (up): ip 192.168.123.2 dlci 301, static,
broadcast,
CISCO, status defined, active
Serial0/0/0.1 (up): ip 192.168.123.3 dlci 301, static,
CISCO, status defined, active
R3#ping 192.168.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 35/42/51 ms
R3#ping 192.168.123.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 13/23/32 ms
R3#ping 192.168.123.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 34/38/45 ms
不积跬步无以至千里,不积小流无以成江海;
千里之行,始于足下;
每天一个小实验。