著名的王牌间谍 007 需要执行一次任务,获取敌方的机密情报。已知情报藏在一个地下迷宫里,迷宫只有一个入口,里面有很多条通路,每条路通向一扇门。每一扇门背后或者是一个房间,或者又有很多条路,同样是每条路通向一扇门…… 他的手里有一张表格,是其他间谍帮他收集到的情报,他们记下了每扇门的编号,以及这扇门背后的每一条通路所到达的门的编号。007 发现不存在两条路通向同一扇门。
内线告诉他,情报就藏在迷宫的最深处。但是这个迷宫太大了,他需要你的帮助 —— 请编程帮他找出距离入口最远的那扇门。
输入格式:
输入首先在一行中给出正整数 N(<105),是门的数量。最后 N 行,第 i 行(1≤i≤N)按以下格式描述编号为 i 的那扇门背后能通向的门:
K D[1] D[2] ... D[K]
其中 K
是通道的数量,其后是每扇门的编号。
输出格式:
在一行中输出距离入口最远的那扇门的编号。题目保证这样的结果是唯一的。
输入样例:
13
3 2 3 4
2 5 6
1 7
1 8
1 9
0
2 11 10
1 13
0
0
1 12
0
0
输出样例:
12
做法:
1.建图(用邻接表存图)
2.搜索图
说一下:
dfs将 每个与1连通的点 到1的距离算出来了,所以还要 遍历一次 距离数组 才知道答案是谁
bfs队尾最后一个元素即是答案(题目保证结果是唯一的)。
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int N = 100010;
int h[N],e[2 * N],ne[2 * N],idx;
int dist[N],ans;
int q[N];
int n = 0;
void add(int a,int b)
{
e[idx] = b,ne[idx] = h[a],h[a] = idx++;
}
void dfs(int u,int cnt)
{
dist[u] = cnt;
for(int i = h[u];i != -1;i = ne[i])
{
int j = e[i];
if(!dist[j]) dfs(j,cnt + 1);
}
}
int bfs(int u)
{
int hh = 0,tt = -1;
dist[u] = 1;
q[++tt] = u;
while(hh <= tt)
{
int t = q[hh++];
for(int i = h[t];i != -1;i = ne[i])
{
int j = e[i];
if(!dist[j])
{
dist[j] = dist[t] + 1;
q[++tt] = j;
}
}
}
return q[tt];
}
int main()
{
scanf("%d",&n);
memset(h,-1,sizeof h);
for(int i = 1;i <= n;i++)
{
int k = 0;
scanf("%d",&k);
while(k--)
{
int b = 0;
scanf("%d",&b);
add(i,b),add(b,i);
}
}
// dfs(1,1);//dfs
// for(int i = 1;i <= n;i++)
// if(dist[i] > dist[ans]) ans = i;
// printf("%d\n",ans);
printf("%d\n",bfs(1));//bfs
return 0;
}