题目描述
没有人没抢过红包吧…… 这里给出N个人之间互相发红包、抢红包的记录,请你统计一下他们抢红包的收获。
输入格式:
输出格式:
按照收入金额从高到低的递减顺序输出每个人的编号和收入金额(以元为单位,输出小数点后2位)。每个人的信息占一行,两数字间有1个空格。如果收入金额有并列,则按抢到红包的个数递减输出;如果还有并列,则按个人编号递增输出。
输入样例:
10
3 2 22 10 58 8 125
5 1 345 3 211 5 233 7 13 8 101
1 7 8800
2 1 1000 2 1000
2 4 250 10 320
6 5 11 9 22 8 33 7 44 10 55 4 2
1 3 8800
2 1 23 2 123
1 8 250
4 2 121 4 516 7 112 9 10
输出样例:
1 11.63
2 3.63
8 3.63
3 2.11
7 1.69
6 -1.67
9 -2.18
10 -3.26
5 -3.26
4 -12.32
题解:
只能19分了,有一个超时,不知道再怎么优化
import java.util.Arrays;
import java.util.Scanner;
class Person {
int num; //编号
double money;
int count; //抢到红包的个数
}
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int N = scanner.nextInt();
Person[] people = new Person[N];
for (int i = 0; i < N; i++) { //初始化结构体数组
people[i] = new Person();
people[i].num = i + 1;
people[i].count = 0;
people[i].money = 0;
}
for (int i = 0; i < N; i++) { //输入发红包,抢红包数据
int n = scanner.nextInt();
for (int j = 0; j < n; j++) {
int m = scanner.nextInt();
int money = scanner.nextInt();
people[i].money -= money;
people[m - 1].money += money;
people[m - 1].count++;
}
}
Arrays.sort(people, (p1, p2) -> { //排序
if (p1.money == p2.money) {
if (p1.count == p2.count) {
return p1.num - p2.num;
}
return p2.count - p1.count;
}
return Double.compare(p2.money, p1.money);
});
for (int i = 0; i < N; i++) { //输出
System.out.print(people[i].num + " ");
System.out.printf("%.2f\n", people[i].money / 100);
}
}
}