背景:
平时在vmware中做实验时候,经常需要在不同的机器上下载一些github上的项目进行调试,之前解决方案是在路由器层小米ac2100上装openwrt,试用一番发现太卡了。放弃,这次在vmware中安装作为小米ac2100的旁路由
规划:
网卡规划
两块网卡 顺序不能颠倒
第一块网卡:
vmnet8
vmware workstation自带vmnet网卡模式 对应lan口
vmnet5 自定义桥接到宿主机有线网卡 对应wan口
网络规划
小米ac2100路由器网段是192.168.6.0/24
vmnet5网段也是192.168.6.0/24
vmnet8 网段和虚拟机中的vmnet8保持一致即可
实施
vmware中的客户机操作系统类型
网卡配置
下载img镜像
https://downloads.openwrt.org/releases/22.03.0-rc6/targets/x86/64/generic-ext4-combined-efi.img.gz
使用qemu-img工具将img转换为vmdk虚拟磁盘文件直接挂载
root@kktb:kktb#sudo apt update
root@kktb:kktb#sudo apt install qemu-utils
root@kktb:kktb#qemu-img convert -f raw -O vmdk openwrt-22.03.0-rc6-x86-64-generic-ext4-combined-efi.img openwrt-22.03.0-rc6-x86-64-generic-ext4-combined-efi.img.vmdk
开机
刚装好,不能ssh连接的话,可能是防火墙的问题
关闭防火墙
root@OpenWrt:~# /etc/init.d/firewall stop
root@OpenWrt:~# /etc/init.d/firewall status
inactive
配置网络
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd99:ce59:984a::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ip6assign '60'
option ipaddr '10.0.0.2'
option netmask '255.255.0.0'
# 这块网卡是vmnat5自定义桥接到vmnet5的第二块网卡
config interface 'wan'
option device 'eth1'
option proto 'static'
option ipaddr '192.168.6.66'
option netmask '255.255.255.0'
option gateway '192.168.6.1'
list dns '223.5.5.5' # 配置dns
config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6
剩下的配置就不放出来了。