[NOIP2011 提高组] 铺地毯
题目描述
为了准备一个独特的颁奖典礼,组织者在会场的一片矩形区域(可看做是平面直角坐标系的第一象限)铺上一些矩形地毯。一共有 n n n 张地毯,编号从 1 1 1 到 n n n。现在将这些地毯按照编号从小到大的顺序平行于坐标轴先后铺设,后铺的地毯覆盖在前面已经铺好的地毯之上。
地毯铺设完成后,组织者想知道覆盖地面某个点的最上面的那张地毯的编号。注意:在矩形地毯边界和四个顶点上的点也算被地毯覆盖。
输入格式
输入共 n + 2 n + 2 n+2 行。
第一行,一个整数 n n n,表示总共有 n n n 张地毯。
接下来的 n n n 行中,第 i + 1 i+1 i+1 行表示编号 i i i 的地毯的信息,包含四个整数 a , b , g , k a ,b ,g ,k a,b,g,k,每两个整数之间用一个空格隔开,分别表示铺设地毯的左下角的坐标 ( a , b ) (a, b) (a,b) 以及地毯在 x x x 轴和 y y y 轴方向的长度。
第 n + 2 n + 2 n+2 行包含两个整数 x x x 和 y y y,表示所求的地面的点的坐标 ( x , y ) (x, y) (x,y)。
输出格式
输出共
1
1
1 行,一个整数,表示所求的地毯的编号;若此处没有被地毯覆盖则输出 -1
。
样例 #1
样例输入 #1
3
1 0 2 3
0 2 3 3
2 1 3 3
2 2
样例输出 #1
3
样例 #2
样例输入 #2
3
1 0 2 3
0 2 3 3
2 1 3 3
4 5
样例输出 #2
-1
提示
【样例解释 1】
如下图, 1 1 1 号地毯用实线表示, 2 2 2 号地毯用虚线表示, 3 3 3 号用双实线表示,覆盖点 ( 2 , 2 ) (2,2) (2,2) 的最上面一张地毯是 3 3 3 号地毯。
【数据范围】
对于
30
%
30\%
30% 的数据,有
n
≤
2
n \le 2
n≤2。
对于
50
%
50\%
50% 的数据,
0
≤
a
,
b
,
g
,
k
≤
100
0 \le a, b, g, k \le 100
0≤a,b,g,k≤100。
对于
100
%
100\%
100% 的数据,有
0
≤
n
≤
1
0
4
0 \le n \le 10^4
0≤n≤104,
0
≤
a
,
b
,
g
,
k
≤
10
5
0 \le a, b, g, k \le {10}^5
0≤a,b,g,k≤105。
noip2011 提高组 day1 第 1 1 1 题。
代码如下:
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<istream>
#include<iomanip>
#include<ostream>
#include<list>
#include<vector>
#include<set>
#include<map>
#include<fstream>
#include<stack>
#include<ctime>
#include<deque>
#include<queue>
#include <sstream>
#include <numeric>
#pragma warning (disable:4996)
using namespace std;
struct xy {
int a;
int b;
int g;
int k;
};
int main()
{
int n; cin >> n; vector<xy*>v;
for (int i = 0; i < n; i++)
{
xy* xy1 = new xy;
cin >> xy1->a >> xy1->b >> xy1->g >> xy1->k;
v.push_back(xy1);
}
int x, y; cin >> x >> y; int out = -1;
for (int i = 1; i <= n; i++)
{
if (x >= v[i-1]->a && x <= (v[i-1]->a + v[i-1]->g) && y >= v[i-1]->b && (y <= v[i-1]->b + v[i-1]->k))
{
out = i;
}
}
cout << out << endl;
}