题目描述
评论
请你定义一个链表,可以对链表进行“在某个元素之前插入一些元素”、“删除某个位置的元素”、“查找某元素”、“获取某个位置的元素”、“遍历输出所有元素”、“求链表的长度”等操作。键盘输入一些命令,可以执行上述操作。本题中,链表元素为整数,链表的第一个元素位置为1,链表的最大长度为20。
输入描述
各个命令以及相关数据的输入格式如下:
在某个位置之前插入操作的命令:I,接下来的一行是插入的元素个数n,
下面是n行数据,每行数据有两个值,分别代表插入位置与插入的元素值
查找某个元素:S x,x是要查找的元素值
获取某个位置的元素:G i,i是需要获取的元素位置
删除某个位置的元素:D i,i是被删除的元素位置
求链表的长度:L
遍历输出所有元素:V
当输入的命令为E时,程序结束。
输出描述
当输入的命令为S时,输出要查找元素的位置,如果没找到,输出None
当输入的命令为G时,输出获取的元素值,如果输入的元素位置不正确,
输出“位置不正确”
当输入的命令是D时,输出被删除的那个元素值,如果表空,输出“下溢”,
如果输入的位置不正确,输出“位置不正确”
当输入命令是I时,如果输入的位置不正确,输出“位置不正确”
当输入的命令是L时,输出链表的长度
注意,所有的元素均占一行。
输入样例
I
2
1 1
2 2
S 2
D 1
I
2
1 3
2 4
G 2
L
V
E
输出样例
2
1
4
3
3
4
2
内存阀值:50240K 耗时阀值:5000MS
代码
#include <iostream>
using namespace std;
struct Node {
int _val;
Node* _next;
Node(int val):_val(val), _next(NULL) {}
};
class List {
public:
List();
~List();
public:
void Insert(int pos, int val);
int Search(int val);
int Get(int pos);
int Delete(int pos);
int getLength();
void Print();
private:
Node* head_;
int length_;
};
List::List() {
head_ = new Node(-1);
length_ = 0;
}
List::~List() {
Node* previousNext = NULL;
for (Node* p = head_; p != NULL; p = previousNext) {
previousNext = p->_next;
delete p;
}
}
void List::Insert(int pos, int val) {
if (pos < 1) throw "位置不正确";
int count = 0;
Node* node = new Node(val);
for (Node* p = head_; p != NULL; p = p->_next) {
if (count + 1 == pos) {
node->_next = p->_next;
p->_next = node;
}
count++;
}
length_++;
}
int List::Search(int val) {
int count = 0;
int pos;
bool isFind = false;
for (Node* p = head_; p != NULL; p = p->_next) {
if (p->_val == val) {
isFind = true;
pos = count;
break;
}
count++;
}
if (isFind == false) throw "None";
return pos;
}
int List::Delete(int pos) {
if (length_ == 0) throw "下溢";
if (pos < 1 || pos > length_) throw "位置不正确";
int count = 0;
int val;
Node* DeletedNode = NULL;
for (Node* p = head_; p != NULL; p = p->_next) {
if (count + 1 == pos) {
DeletedNode = p->_next;
val = DeletedNode->_val;
p->_next = p->_next->_next;
delete DeletedNode;
break;
}
count++;
}
length_--;
return val;
}
int List::Get(int pos) {
if (pos < 1 || pos > length_) throw "位置不正确";
int count = 0;
int val;
for (Node* p = head_; p != NULL; p = p->_next) {
if (count == pos) {
val = p->_val;
break;
}
count++;
}
return val;
}
int List::getLength() {
return length_;
}
void List::Print() {
for (Node* p = head_->_next; p != NULL; p = p->_next)
cout << p->_val ;
}
int main() {
List list;
char command;
int n, pos, val;
while (cin >> command) {
if (command == 'E') break;
try {
switch (command) {
case 'I':
cin >> n;
for (int i = 0; i < n; i++) {
cin >> pos >> val;
list.Insert(pos, val);
}
break;
case 'S':
cin >> val;
cout << list.Search(val);
break;
case 'G':
cin >> pos;
cout << list.Get(pos);
break;
case 'D':
cin >> pos;
cout << list.Delete(pos) ;
break;
case 'L':
cout << list.getLength() ;
break;
case 'V':
list.Print();
break;
}
} catch (const char* str) {
cout << str ;
}
}
return 0;
}