早餐店卖出三种包子,牛肉馅的3元一个,猪肉馅的2元一个,素馅的1元一个,小明的母亲给小明一笔钱,让小明去买包子,要求每一种馅的包子都要有,小明一共有多少种组合方式?
输入格式:
输入小明的母亲给小明的钱数(一个在大于等于6和小于等于100之间的正整数)
输出格式:
要求按cattle、pig和vegetable的顺序,依次从小到大输出各种馅的包子的数量。每行输出一种换法:
cattle=牛肉馅包子数量,pig=猪肉馅包子的数量,vegetable=素馅包子的数量
输入样例:
在这里给出一组输入。例如:
10
输出样例:
在这里给出相应的输出。例如:
cattle=1,pig=1,vegetable=5
cattle=1,pig=2,vegetable=3
cattle=1,pig=3,vegetable=1
cattle=2,pig=1,vegetable=2
//自己写的
#define _CRT_SECURE_NO_WARNINGS 1
#include <stdio.h>
#include <stdlib.h>
int main()
{
int money, tem;
int x = 1, y = 1, z = 1;
scanf("%d", &money);
money = money - 6;
tem = money;
while (tem < 3)
{
z = z + tem;
printf("cattle=%d,pig=%d,vegetable=%d\n", x, y, z);
while (z > 2)
{
z = z - 2;
y++;
tem = tem - 2;
printf("cattle=%d,pig=%d,vegetable=%d\n", x, y, z);
}
break;
}
while (tem>=3)
{
z = z + tem;
printf("cattle=%d,pig=%d,vegetable=%d\n", x, y, z);
while (z>2)
{
z = z - 2;
y++;
printf("cattle=%d,pig=%d,vegetable=%d\n", x, y, z);
}
if(money>3)
{
x++;
y = 1;
tem = tem - 3;
z = 1 + tem;
printf("cattle=%d,pig=%d,vegetable=%d\n", x, y, z);
}
}
return 0;
}