概述:PPP模式,即公私合作模式(Public-Private Partnership),是一种公共部门与私营部门合作的模式。
一、实验拓扑
实验一:PPP基本功能
实验步骤:
(1)配置AR1的接口IP地址并配置PPP协议,命令如下:
<Huawei>system-view
[Huawei]undo info-center enable
[Huawei]sysname AR1
[AR1]interface s4/0/0
[AR1-Serial4/0/0]link-protocol ppp //将链路层协议封装为PPP
[AR1-Serial4/0/0]ip address 10.0.12.1 24
[AR1-Serial4/0/0]quit
(2)配置全局地址池,命令如下:
[AR1]ip pool 1 //创建地址池编号为1
[AR1-ip-pool-1]network 10.0.12.0 mask 24 //设置地址和子网掩码
[AR1-ip-pool-1]gateway-list 10.0.12.1 //网关为10.0.12.1
[AR1-ip-pool-1]quit
(3)配置为客户端指定的地址池,命令如下:
[AR1-Serial4/0/0]remote address pool 1
(4)在AR2配置接口Serial4/0/0的链路层协议和IP地址的可协商属性,命令如下:
<Huawei>system-view
[Huawei]sysname AR2
[AR2]interface s4/0/0
[AR2-Serial4/0/0]link-protocol ppp
[AR2-Serial4/0/0]ip address ppp-negotiate //通过PPP协商的方式获取IP地址
(5)查看接口是否获取IP地址,命令如下:
[AR2-Serial4/0/0]display ip interface brief
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 2
The number of interface that is DOWN in Physical is 4
The number of interface that is UP in Protocol is 2
The number of interface that is DOWN in Protocol is 4
Interface IP Address/Mask Physical Protocol
GigabitEthernet0/0/0 unassigned down down
GigabitEthernet0/0/1 unassigned down down
GigabitEthernet0/0/2 unassigned down down
NULL0 unassigned up up(s)
Serial4/0/0 10.0.12.254/32 up up
Serial4/0/1 unassigned down down
实验二:PAP认证
实验二拓扑:
实验步骤:
(1)配置AR1的接口IP地址,命令如下:
<Huawei>system-view
[Huawei]undo info-center enable
[Huawei]sysname AR1
[AR1]interface s4/0/0
[AR1-Serial4/0/0]link-protocol ppp
[AR1-Serial4/0/0]ip address 10.0.12.1 24
[AR1-Serial4/0/0]quit
(2)配置认证用户密码,命令如下:
[AR1]aaa
[AR1-aaa]local-user huawei password cipher huawei //配置认证时使用的用户密码
[AR1-aaa]local-user huawei service-type ppp //将用户名为huawei的服务类型改为PPP
(3)在接口配置认证模式为PAP认证,命令如下:
[AR1]interface s4/0/0
[AR1-Serial4/0/0]ppp authentication-mode pap
(4)配置AR2的接口IP地址,命令如下:
<Huawei>system-view
[Huawei]undo info-center enable
[Huawei]sysname AR2
[AR2]interface s4/0/0
[AR2-Serial4/0/0]link-protocol ppp
[AR2-Serial4/0/0]ip address 10.0.12.2 24
[AR2-Serial4/0/0]quit
(5)在AR2的接口配置认证用户名及密码,命令如下:
[AR2]interface s4/0/0
[AR2-Serial4/0/0]ppp pap local-user huawei password cipher huawei
(6)在AR2设备上查看接口状态,命令如下:
<AR2>display interface Serial4/0/0
Serial4/0/0 current state : UP
Line protocol current state : DOWN
Description:HUAWEI, AR Series, Serial4/0/0 Interface
Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)
Internet protocol processing : disabled
Link layer protocol is PPP
LCP stopped
Last physical up time : 2024-09-18 19:38:19 UTC-08:00
Last physical down time : 2024-09-18 19:38:09 UTC-08:00
Current system time: 2024-09-18 19:41:44-08:00
Physical layer is synchronous, Virtualbaudrate is 64000 bps
Interface is DTE, Cable type is V11, Clock mode is TC
Last 300 seconds input rate 3 bytes/sec 24 bits/sec 0 packets/sec
Last 300 seconds output rate 1 bytes/sec 8 bits/sec 0 packets/sec
Input: 28 packets, 1022 bytes
Broadcast: 0, Multicast: 0
Errors: 0, Runts: 0
Giants: 0, CRC: 0
Alignments: 0, Overruns: 0
Dribbles: 0, Aborts: 0
No Buffers: 0, Frame Error: 0
Output: 28 packets, 392 bytes
Total Error: 0, Overruns: 0
Collisions: 0, Deferred: 0
Input bandwidth utilization : 0%
Output bandwidth utilization : 0%
通过以上输出结果可以发现,LCP和IPCP的状态为opened,并且物理状态和协议状态都为UP。
实验三:CHAP的认证
实验拓扑:
实验步骤:(1)配置AR1的接口IP地址,命令如下:
<Huawei>system-view
[Huawei]undo info-center enable
[Huawei]sysname s4/0/0
[s4/0/0]sysname AR1
[AR1]interface s4/0/0
[AR1-Serial4/0/0]link-protocol ppp
[AR1-Serial4/0/0]ip address 10.0.12.1 24
[AR1-Serial4/0/0]quit
(2)配置AR2的接口IP地址,命令如下:
<Huawei>system-view
[Huawei]undo info-center enable
[Huawei]sysname AR2
[AR2]interface s4/0/0
[AR2-Serial4/0/0]ip address 10.0.12.2 24
[AR2-Serial4/0/0]link-protocol ppp
[AR2-Serial4/0/0]quit
(3)在认证方AR1上配置用户名和密码,用户被认证方用户的登录,命令如下:
[AR1]aaa
[AR1-aaa]local-user huawei password cipher huawei
[AR1-aaa]local-user huawei service-type ppp
[AR1-aaa]quit
(4)在认证方接口配置PPP的认证模式为CHAP认证,命令如下:
[AR1]interface s4/0/0
[AR1-Serial4/0/0]ppp authentication-mode chap
(5)在被认证方接口配置CHAP认证的用户名和密码,命令如下:
[AR2]interface s4/0/0
[AR2-Serial4/0/0]ppp chap user huawei
[AR2-Serial4/0/0]ppp chap password cipher huawei
(6)在AR2设备上查看接口状态,命令如下:
[AR2]display interface s4/0/0
Serial4/0/0 current state : UP
Line protocol current state : UP
Last line protocol up time : 2024-09-21 16:05:09 UTC-08:00
Description:HUAWEI, AR Series, Serial4/0/0 Interface
Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)
Internet Address is 10.0.12.2/24
Link layer protocol is PPP
LCP opened, IPCP opened
Last physical up time : 2024-09-21 16:05:06 UTC-08:00
Last physical down time : 2024-09-21 16:05:02 UTC-08:00
Current system time: 2024-09-21 16:23:32-08:00
Physical layer is synchronous, Virtualbaudrate is 64000 bps
Interface is DTE, Cable type is V11, Clock mode is TC
Last 300 seconds input rate 6 bytes/sec 48 bits/sec 0 packets/sec
Last 300 seconds output rate 2 bytes/sec 16 bits/sec 0 packets/sec
Input: 224 packets, 7184 bytes
Broadcast: 0, Multicast: 0
Errors: 0, Runts: 0
Giants: 0, CRC: 0
Alignments: 0, Overruns: 0
Dribbles: 0, Aborts: 0
No Buffers: 0, Frame Error: 0
Output: 225 packets, 2722 bytes
Total Error: 0, Overruns: 0
Collisions: 0, Deferred: 0
Input bandwidth utilization : 0%
Output bandwidth utilization : 0%
---- More ----
总结:
PPP的配置实验通过模拟实际操作,加深了对PPP协议工作原理、子网划分和静态路由配置的理解,并验证了其在网络通信中的应用效果。以下是具体介绍:
- 实验目的
- 掌握基本配置:使学生掌握PPP帧的结构,理解PPP帧格式中每个字段的含义,并了解PPP协议中数据实际传送状况。
- 理解工作机制:通过实验,学生能够理解PPP协议在点对点连接中的工作过程,包括链路建立、身份验证和数据传输。
- 实验步骤
- 创建实验拓扑:使用华为eNSP软件或其他模拟器,创建包含两台路由器的网络拓扑,并配置同异步WAN接口卡。
- 配置路由器接口:为每台路由器的串口配置PPP协议,设置IP地址,并启用PAP或CHAP认证。
- 验证网络连通性:通过ping命令测试两台路由器之间的网络连通性,确保PPP连接正常工作。
- 实验结果
- 成功建立连接:实验结果表明,通过正确配置PPP协议和认证方式,可以在两台路由器之间成功建立点对点连接。
- 抓包分析:使用Wireshark等抓包工具,可以观察到PPP连接过程中的数据包交换情况,进一步理解PPP协议的工作机制。
- 实验总结
- 深化理解:通过实验,学生不仅掌握了PPP协议的基本配置方法,还深入了解了其在不同场景下的应用,如同步/异步专线、拨号链路等。
- 实践能力提升:实验过程中的操作练习,提高了学生的动手能力和解决实际问题的能力,为未来从事网络相关工作打下了坚实基础。