[PTA]7-1 谁管谁叫爹
输入格式:
输入第一行给出一个正整数 N(≤100),为游戏的次数。以下 N 行,每行给出一对不超过 9 位数的正整数,对应 A 和 B 给出的原始数字。题目保证两个数字不相等。
输出格式:
对每一轮游戏,在一行中给出赢得“爹”称号的玩家(A 或 B)。
输入样例:
4
999999999 891
78250 3859
267537 52654299
6666 120
输出样例:
B
A
B
A
代码
#include <stdio.h>
int qiu_he(int);
int main(){
int N;
scanf("%d",&N);
while(N-->0){
int NA, NB;
scanf("%d",&NA);
scanf("%d",&NB);
int SA=qiu_he(NA),SB=qiu_he(NB);
if (NA % SB==0 ){
if(NB%SA==0){
putchar('A'+(NA<NB));
}
else{
putchar('A');
}
}
else{
if (NB%SA==0){
putchar('B');
}
else{
putchar('A'+(NA<NB));
}
}
putchar('\n');
}
return 0;
}
int qiu_he(int s){
int he=0;
do{
he+=s%10;
}
while((s/=10)!=0) ;
return he;
}