本题要求编写函数,将输入字符串t中从第m个字符开始的全部字符复制到字符串s中。
函数接口定义:
void strmcpy( char *t, int m, char *s );
函数strmcpy将输入字符串char *t中从第m个字符开始的全部字符复制到字符串char *s中。若m超过输入字符串的长度,则结果字符串应为空串。
输入样例:
7
happy new year
输出样例:
new year
程序:
#define _CRT_SECURE_NO_WARNINGS 1
#include <stdio.h>
#include<string.h>
#define MAXN 20
void strmcpy(char* t, int m, char* s);
//void ReadString(char s[]); /* 由裁判实现,略去不表 */
int main()
{
char t[MAXN], s[MAXN];
int m;
scanf("%d\n", &m);
gets(t);
strmcpy(t, m, s);
printf("%s\n", s);
return 0;
}
//指针法
void strmcpy(char* t, int m, char* s)
{
while (*(t+m-1))
{
*s = *(t+m-1);
s++;
m++;
}
/**s = *(t+m-1);*/
*s = '\0';
}
效果如下: