给定 n 个正整数 ,对于每个整数 ,请你按照从小到大的顺序输出它的所有约数。
输入格式
第一行包含整数 n。
接下来 n 行,每行包含一个整数 。
输出格式
输出共 n 行,其中第 i 行输出第 i 个整数 的所有约数。
数据范围
1≤n≤100,
1≤ai≤2×
输入样例:
2
6
8
输出样例:
1 2 3 6
1 2 4 8
代码:
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int n,x;
int main(){
cin>>n;
while(n--){
cin>>x;
vector<int> now;
now.push_back(1);
if(x != 1){
now.push_back(x);
}
for(int i = 2;i <= x / i;i++){
if(x % i == 0){
now.push_back(i);
if(i != x / i){
now.push_back(x / i);
}
}
}
sort(now.begin(),now.end());
for(auto k:now){
cout<<k<<" ";
}
cout<<endl;
}
}