上面大概讲了配置的思路与原理,这里开始实际配置下。
一般建议采用旁挂AC,然后划分独立的设备管理网段,通过DHCP进行获取地址,其它的地址、接口、路由正常配置即可。
一、基本配置
AR1:
# 配置接口地址和路由
interface GigabitEthernet0/0/0
ip address 10.0.0.1 255.255.255.252
#
ip route-static 192.168.10.0 255.255.255.0 10.0.0.2
ip route-static 192.168.20.0 255.255.255.0 10.0.0.2
ip route-static 192.168.30.0 255.255.255.0 10.0.0.2
核心交换机SW1:
# 创建VLAN
vlan batch 10 20 30 100
# 开启DHCP
dhcp enable
#
vlan 10
description network
vlan 20
description MGT
vlan 30
description wifi-user
# 创建DHCP全局地址池,VLAN20配置option43
ip pool vlan10
gateway-list 192.168.10.254
network 192.168.10.0 mask 255.255.255.0
dns-list 114.114.114.114
#
ip pool vlan20
gateway-list 192.168.20.254
network 192.168.20.0 mask 255.255.255.0
option 43 sub-option 1 ip-address 192.168.20.253
#
ip pool vlan30
gateway-list 192.168.30.254
network 192.168.30.0 mask 255.255.255.0
dns-list 114.114.114.114 8.8.8.8
# 调用全局地址池
interface Vlanif10
description network
ip address 192.168.10.254 255.255.255.0
dhcp select global
#
interface Vlanif20
description MGT
ip address 192.168.20.254 255.255.255.0
dhcp select global
#
interface Vlanif30
description wifi-user
ip address 192.168.30.254 255.255.255.0
dhcp select global
# 用于与路由器互联
interface Vlanif100
ip address 10.0.0.2 255.255.255.252
# 配置对应的接口类型,有线ACCESS VLAN 10,AC和POESW配置trunk
interface GigabitEthernet0/0/1
port link-type access
port default vlan 100
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 10
#
interface GigabitEthernet0/0/3
port link-type access
port default vlan 10
#
interface GigabitEthernet0/0/4
description poe
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/5
description to-AC
port link-type trunk
port trunk allow-pass vlan 2 to 4094
POESW:配置VLAN和接口
# 创建VLAN
vlan batch 10 20 30
#
interface Vlanif10
#
interface Vlanif20
#
interface Vlanif30
# 与核心连接接口配置trunk
interface Ethernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
# 这里需要通过pvid打上VLAN20标签,设置trunk,用于集中转发模式,如果是隧道转发可以配置为access vlan 20
interface Ethernet0/0/2
port link-type trunk
port trunk pvid vlan 20
port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/3
port link-type trunk
port trunk pvid vlan 20
port trunk allow-pass vlan 2 to 4094
AC配置:接口和地址以及路由
# 创建VLAN,这里30也需要创建,等下配置业务VLAN需要在模版使用
vlan batch 10 20 30
# 配置AC管理地址
interface Vlanif20
ip address 192.168.20.253 255.255.255.0
#
interface Vlanif30
# 与核心相连接口为trunk
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
# 配置默认路由指向核心交换机
ip route-static 0.0.0.0 0.0.0.0 192.168.20.254
基本配置差不多了,检查AP是否获取到地址,能否和AC通信。下面开始配置无线业务如wifi信号,认证,添加AP等等。
二、 业务配置
下面都是在AC上进行配置。
2.1 创建自定义AP组,添加AP
先记录下AP信息,一般新的设备上面会有相关信息。
# 首先所有无线配置需要进入wlan视图
[AC6005]wlan
[AC6005-wlan-view]
# 创建一个名称为apgroup的组
[AC6005-wlan-view]ap-group name apgroup
# 退回wlan视图,手动创建AP,开启sn认证
[AC6005-wlan-view]ap auth-mode sn-auth
# 新增AP,通过配置mac和sn,type进行添加,修改ap名称和加入组是进入ap视图修改的
ap-id 0 ap-mac 00e0-fc6e-3b60 ap-sn 210235448310B137DB0B
ap-name ap01
ap-group apgroup
ap-id 1 ap-mac 00e0-fc4a-4ca0 ap-sn 210235448310B06EA55E
ap-name ap02
ap-group apgroup
# 在全局视图下配置源接口或源地址,配置地址或者接口
[AC6005]capwap source interface Vlanif 20
# 配置自定义域模版,进入域管理模板视图,配置国家码
[AC6005-wlan-view]regulatory-domain-profile name domainmoban
[AC6005-wlan-regulate-domain-domainmoban]country-code CN
# 将域配置模板引入ap组,因为之前ap已经加入组,相当于AP继承了域模版,默认就是CN,其实可以省略
[AC6005-wlan-view]ap-group name apgroup
[AC6005-wlan-ap-group-apgroup]regulatory-domain-profile domainmoban
查看AP是否正常上线。
2.2 配置AP射频信号
进入AP视图,radio有0-2 ,一般情况下,0代表射频2.4G 射频1 和 2为5G射频,可以使用默认配置。
# 进入第一个ap01配置
[AC6005-wlan-view]ap-id 0
[AC6005-wlan-ap-0]dis this
# 分别配置不同的频宽和信道,2.4G非重叠信道为1,6,11,5G都是非重叠信道,但是要考虑相邻AP干扰
ap-name ap01
ap-group apgroup
radio 0
channel 20mhz 1
radio 1
channel 80mhz 36
radio 2
channel 80mhz 149
# 配置发射功能,默认是最大
[AC-wlan-radio-0/0] eirp eirp
2.3 业务模版
配置SSID模板,也就是wifi名字
# 创建一个ssid模版,然后设置一个wifi信号名称
[AC6005-wlan-view]ssid-profile name wifi-1
[AC6005-wlan-ssid-prof-wifi-1]ssid wifi-1
配置安全模板,是否认证与认证协议
[AC6005-wlan-view]security-profile name security-wifi1
[AC6005-wlan-sec-prof-security-wifi1]security wpa2 psk pass-phrase 12345678 aes
创建VAP模板,将SSID模板、安全配置模板,配置业务VLAN就是客户端获取地址的VLAN30以及转发模式(集中/隧道)
[AC6005-wlan-view]vap-profile name vap-wifi1
[AC6005-wlan-vap-prof-vap-wifi1]service-vlan vlan-id 30
[AC6005-wlan-vap-prof-vap-wifi1]ssid-profile wifi-1
[AC6005-wlan-vap-prof-vap-wifi1]security-profile security-wifi1
[AC6005-wlan-vap-prof-vap-wifi1]forward-mode direct-forward
在AP组里面调用VAP模板
# 进入ap组,调用vap模板,在所有射频上,也可以不同的射频使用不同的VAP,比如2.4G和5G分别设置
[AC6005-wlan-view]ap-group name apgroup
[AC6005-wlan-ap-group-apgroup]vap-profile vap-wifi1 wlan 1 radio all
通过上面的配置可以实现终端正常访问网络。
如果对文章感兴趣欢迎微信搜索公众号:不喜欢热闹的孩子
本文由 mdnice 多平台发布