PPPOE原理与配置
- 实验拓扑图
- 实现步骤
- 家庭网关 AR201
- PPPOE客户端( ISP光猫)
- PPPOE服务器(ISP路由器)
实验拓扑图
实现步骤
家庭网关 AR201
- E0/0/0-7为LAN口(二层接口)
- E0/0/8为WAN口(三层接口)
sysname GW
//开启设备DHCP
dhcp enable
//配置ACL 默认允许所有
acl number 2000
rule 5 permit
//配置PC网关,自动分配IP地址。
interface Vlanif1
ip address 192.168.110.1 255.255.255.0
dhcp select interface
//使用easy-ip,wan口自动获取IP地址
interface Ethernet0/0/8
nat outbound 2000
ip address dhcp-alloc
PPPOE客户端( ISP光猫)
sysname ISPModem
//开启设备DHCP
dhcp enable
//配置ACL 默认允许所有
acl number 2000
rule 5 permit
//配置PPPOE客户端
interface Dialer1 //创建拨号接口
link-protocol ppp //使用PPP协议
ppp chap user wml //用户名
ppp chap password cipher wml //密码
ip address ppp-negotiate //PPP协商地址
dialer user wml //启用拨号功能,名称wml
dialer bundle 100 //绑定拨号ID为100
nat outbound 2000 //在拨号接口上启用easy-IP
//网络侧物理接口关联拨号ID100的接口
interface GigabitEthernet0/0/0
pppoe-client dial-bundle-number 100
//用户侧物理接口启用DHCP
interface GigabitEthernet0/0/1
ip address 192.168.0.1 255.255.255.0
dhcp select interface
//配置默认路由
ip route-static 0.0.0.0 0.0.0.0 Dialer1
查看有没有获取到正确的IP地址
PPPOE服务器(ISP路由器)
sysname ISP
//创建地址池,名称为PPPOE
ip pool PPPOE
gateway-list 100.1.1.1
network 100.1.1.0 mask 255.255.255.0
//配置AAA
aaa
domain wml
local-user wml password cipher wml
local-user wml service-type ppp
//配置PPPOE服务端
interface Virtual-Template0 //创建虚拟面板
ppp authentication-mode chap //启用chap认证
remote address pool PPPOE //分配远端地址
ip address 100.1.1.1 255.255.255.0
//物理接口关联虚拟面板
interface GigabitEthernet0/0/0
pppoe-server bind Virtual-Template 0
//配置环回口IP地址
interface LoopBack0
ip address 114.114.114.114 255.255.255.255