输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T
这题是建最小堆,数据结构牛老师讲过这个知识点,但是我给忘了,补题搜了一下才解出来,斯密马噻!!!
#include "bits/stdc++.h"
using namespace std;
const int N = 1e4;
int t[N];
int n;
int find(int x){
for(int i = 1; i <= n; i ++){
if(t[i] == x) return i;
}
}
int main(){
int m;
cin>>n>>m;
for(int i = 1; i <= n; i ++){
cin>>t[i];
if(i > 1){
int tt = i;
while( tt > 1 && t[tt] < t[tt / 2]){
swap(t[tt], t[tt / 2]);
tt /= 2;
}
}
}
while(m--){
int x, y;//用于判断的节点
string s1, s2, s3,s4;
cin>>x>>s1;
if(s1 == "and"){
cin>>y>>s2>>s3;
if(find(x) / 2 == find(y)/ 2) cout<<"T";
else cout<<"F";
}
else{
cin>>s2;
if(s2 == "a") {
cin>>s3>>s4>>y;
if(find(x)/2 == find(y) ) cout<<"T";
else cout<<"F";
}
else {
cin>>s3;
if(s3 == "root"){
if(find(x) == 1) cout<<"T";
else cout<<"F";
}
else {
cin>>s4>>y;
if(find(x) == find(y)/ 2) cout<<"T";
else cout<<"F";
}
}
}
if(m != 0) cout<<endl;
}
return 0;
}