1)PPP协议
1. 选择2620系列交换机,添加WIC-2t模块,具有两个serial串行接口;
2.Router>enable:进入特权模式
Router#configure terminal:全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface serial 0/0:进入0号串行接口
Router(config-if)#ip address 192.168.1.1 255.255.255.0:配置IP
Router(config-if)#clock rate 128000:设置0号串行接口作为DCE设备,向DTTE端提供速率为128000的时钟
Router(config-if)#encapsulation ppp:封装PPP协议;
Router(config-if)#shutdown:暂时停用端口,以便后续打开然后捕获报文
3.另一个路由器配置
Enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface serial 0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#encapsulation ppp
Router(config-if)#shutdown
输入 no shutdown启用端口;
(2)以太网协议分析:
1.
Router>enable
Router#confi
Router#configure te
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#inter
Router(config)#interface fa
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
2.
Router>en
Router>enable
Router#configure
Router#configure te
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#inter
Router(config)#interface fa
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#no shutdown
2. 路由器之间使用ping命令测试连通性:
(3)802.11协议分析:
1)在802.11无线协议标准中,定义了基本服务集BSS和拓展服务集ESS:
BSS基本服务集:由无线站及中心站组成;
(固定站)中心站称为access point接入点AP;没有AP的BSS称为自组织体系结构;具有AP的BSS称为基础结构网络;
Ess拓展服务集:由两个或多个具有多个接入点的BSS组成;BSS连接到一个DISTRIBUTION SYSTEM分配系统DS,分配系统连接网络的AP;
2)站类型分类:ess切换:可以从当前ESS移动到其他ESS;
bss切换:在一个ESS控制下的多个BSS范围内移动;
无切换:在一个BSS范围内移动或者固定不动;
3) MAC子层:
4) 定义两种子层:
5) 常用为在csma with collision avoidance带碰撞避免的载波侦听多点接入CSMA/CA的MAC子层:
6) 帧交换时序:10
7) 源站在发送帧之前,检查信道是否空闲,如果忙,使用带退避的坚持策略等待信道空闲,如果空闲则先等待DIFS分布帧间距distributed interframe space的时间,然后发送称为请求发送的请求帧RTS;目的站收到以后,等待SIFS短帧间距short interframe space,然后回送CTS允许发送的数据帧,源站收到后等待DIFS时间后发送数据,接收方收到后等待SIFS时间后后发送确认;
8) 网络分配矢量:802.11协议使用NAV网络分配矢量network allocaation vector解决碰撞问题;站点发送帧时,在帧中标识需要占用信道的时间,涉及站点需要创建一个定时器NAV,标识其他站检测信道是否空闲前必须等待时间;
在传送RTS或者CTS控制帧之前,通常称为握手期,发生了碰撞,如果没有收到CTS帧。认为发生了碰撞;
IP层协议
IPV4协议:
路由器2,3,5都安装WIC-2T模块,将其拖动到右边端口上;
网络结构如图所示:
对路由器3:
Router>enable
Router#conf
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int
Router(config)#interface fa
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#inter
Router(config)#interface se 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to down
Router(config-if)#exit
Router(config)#interface se0/1
Router(config-if)#ip address 192.168.3.2 255.255.255.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1, changed state to down
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.4.0
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console
write
Building configuration...
[OK]
Router#write
Building configuration...
[OK]
Router#
配置路由器2:
Router>enable
Router#con
Router#conf
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface se0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to down
Router(config-if)#exit
Router(config)#intterface se0/1
^
% Invalid input detected at '^' marker.
Router(config)#interface se0/1
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/1, changed state to up
Router(config-if)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#exit
配置路由器5:
Router>enable
Router#confi
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface se0/1
Router(config-if)#ip address 192.168.3.1
% Incomplete command.
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/1, changed state to up
Router(config-if)#exit
Router(config)#i
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
Router(config)#interface se0/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
Router(config-if)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
i
% Ambiguous command: "i"
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.5.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.5.0
配置路由器4
Router>enable
Router#conf
Router#configure ter
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.4.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip default-gateway 192.168.4.1
配置路由器6
Router>enable
Router#con
Router#conf
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#inter
Router(config)#interface fa
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.5.2 255.255.255.0
Router(config-if)#no shutdown
Router(config)#ip default-gateway 192.168.4.1