Bone Collector
Problem - 2602 (hdu.edu.cn)https://acm.hdu.edu.cn/showproblem.php?pid=2602
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
Author
Teddy
Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contesthttps://acm.hdu.edu.cn/search.php?field=problem&key=HDU+1st+%A1%B0Vegetable-Birds+Cup%A1%B1+Programming+Open+Contest&source=1&searchmode=source
AC代码:(经典01背包问题-只是循环案例数目)
// c++ 代码
#include <iostream>
#include <vector>
#include <algorithm>
#include <tuple>
using namespace std;
struct Case {
int N; // Number of bones
int V; // Capacity of the bag
vector<int> values; // Values of the bones
vector<int> volumes; // Volumes of the bones
};
vector<int> knapsack(int T, vector<Case>& cases) {
vector<int> results;
for (auto& case_ : cases) {
int N = case_.N;
int V = case_.V;
vector<int>& values = case_.values;
vector<int>& volumes = case_.volumes;
// Initialize dp array
vector<int> dp(V + 1, 0);
// Process each bone
for (int i = 0; i < N; ++i) {
for (int j = V; j >= volumes[i]; --j) {
dp[j] = max(dp[j], dp[j - volumes[i]] + values[i]);
}
}
// The maximum value for this case
results.push_back(dp[V]);
}
return results;
}
int main() {
int T;
cin >> T;
vector<Case> cases(T);
for (int t = 0; t < T; ++t) {
int N, V;
cin >> N >> V;
cases[t].N = N;
cases[t].V = V;
cases[t].values.resize(N);
cases[t].volumes.resize(N);
for (int i = 0; i < N; ++i) {
cin >> cases[t].values[i];
}
for (int i = 0; i < N; ++i) {
cin >> cases[t].volumes[i];
}
}
vector<int> results = knapsack(T, cases);
for (int result : results) {
cout << result << endl;
}
return 0;
}