需求:1、R2为ISP,其上只能配置IP地址。
2、R1-R2之间为HDLC封装
3、R2-R3之间为ppp封装,pap认证,R2为主认证方。
4、R2-R4之间为ppp封装,chap认证,R2为主认证方。
5、R1、R2、R3构建MGRE环境,仅R1IP地址固定。
6、内网使用rip获取路由,所有pc可以互相访问,并且可访问R2的环回。
第一步、如图分配IP地址并配置。
第二步、给AR1、AR2、AR3写缺省路由。
[R1]ip route-static 0.0.0.0 0 12.1.1.2
[R3]ip route-static 0.0.0.0 0 23.1.1.1
[R4]ip route-static 0.0.0.0 0 24.1.1.1
第三步、在AR1、AR2、AR3上做nat。
[R1]acl 2000
[R1-acl-basic-2000]rule permit source 192.168.1.0 255.255.255.0
[R1]interface s4/0/0
[R1-Serial4/0/0]nat outbound 2000
[R3]acl 2000
[R3-acl-basic-2000]rule permit source 192.168.2.0 255.255.255.0
[R3-acl-basic-2000]q
[R3]interface s4/0/0
[R3-Serial4/0/0]nat outbound 2000
[R4]acl 2000
[R4-acl-basic-2000]rule permit source 192.168.3.0 255.255.255.0
[R4-acl-basic-2000]q
[R4]interface s4/0/0
[R4-Serial4/0/0]nat outbound 2000
第四步、修改R1-R2之间为hdlc封装。
[R1]interface s4/0/0
[R1-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
[ISP]interface s4/0/0
[ISP-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]:y
第五步、修改R2-R3之间为ppp封装,pap认证,R2为主认证方。
[ISP]aaa
[ISP-aaa]local-user user1 password cipher 123
Info: Add a new user.
[ISP-aaa]local-user user1 service-type ppp
[ISP-aaa]q
[ISP]interface s4/0/1
[ISP-Serial4/0/1]ppp authentication-mode pap
[R3]interface s4/0/0
[R3-Serial4/0/0]ppp pap local-user user1 password cipher 123
第六步、修改R2-R4之间为ppp封装,chap认证,R2为主认证方。
[ISP]aaa
[ISP-aaa]local-user user2 password cipher 123
Info: Add a new user.
[ISP-aaa]local-user user2 service-type ppp
[ISP-aaa]q
[ISP]interface s3/0/0
[ISP-Serial3/0/0]ppp authentication-mode chap
[R4]interface s4/0/0
[R4-Serial4/0/0]ppp chap user user2
[R4-Serial4/0/0]ppp chap password cipher 123
第七步、R1、R2、R3之间构建MGRE。
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 192.168.4.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp
[R1-Tunnel0/0/0]source 12.1.1.1
[R1-Tunnel0/0/0]nhrp entry multicast dynamic
[R1-Tunnel0/0/0]nhrp network-id 100
[R1-Tunnel0/0/0]undo rip split-horizon
[R3]interface Tunnel 0/0/0
[R3-Tunnel0/0/0]ip address 192.168.4.2 24
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp
[R3-Tunnel0/0/0]source s4/0/0
[R3-Tunnel0/0/0]nhrp entry 192.168.4.1 12.1.1.1 register
[R3-Tunnel0/0/0]nhrp network-id 100
[R4]interface Tunnel 0/0/0
[R4-Tunnel0/0/0]ip address 192.168.4.3 24
[R4-Tunnel0/0/0]tunnel-protocol gre p2mp
[R4-Tunnel0/0/0]source s4/0/0
[R4-Tunnel0/0/0]nhrp entry 192.168.4.1 12.1.1.1 register
[R4-Tunnel0/0/0]nhrp network-id 100
第八步、给AR1、AR2、AR3启用rip协议并宣告内网。
[R1]rip 1
[R1-rip-1]version 2
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 192.168.4.0
[R3]rip 1
[R3-rip-1]version 2
[R3-rip-1]network 192.168.2.0
[R3-rip-1]network 192.168.4.0
[R4]rip 1
[R4-rip-1]version 2
[R4-rip-1]network 192.168.3.0
[R4-rip-1]network 192.168.4.0
实验完成。