给定一个单链表 L1→L2→⋯→Ln−1→Ln,请编写程序将链表重新排列为 Ln→L1→Ln−1→L2→⋯。例如:给定L为1→2→3→4→5→6,则输出应该为6→1→5→2→4→3。
输入格式:
每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址和结点总个数,即正整数N (≤105)。结点的地址是5位非负整数,NULL地址用−1表示。
接下来有N行,每行格式为:
Address Data Next
其中Address
是结点地址;Data
是该结点保存的数据,为不超过105的正整数;Next
是下一结点的地址。题目保证给出的链表上至少有两个结点。
输出格式:
对每个测试用例,顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。
输入样例:
00100 6
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
输出样例:
68237 6 00100
00100 1 99999
99999 5 12309
12309 2 00000
00000 4 33218
33218 3 -1
做法:
测试点3的坑点:有多余节点,也就是有节点不在链表上。
1.根据题目信息建立单链表
2.将单链表扩充成双向链表
3.按题目要求输出结果。
注:输出时,先输出尾,再输出头,即是题目要求的输出。
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int N = 100010;
int e[N],l[N],r[N],id;
int main()
{
int head = 0,n = 0;
scanf("%d%d",&head,&n);
for(int i = 0;i < n;i++)
{
int address = 0,data = 0,next = 0;
scanf("%d%d%d",&address,&data,&next);
e[address] = data;r[address] = next;
}
l[head] = -1;
int back = head;//建立双向链表
for(int i = r[head],j = head,cnt = 0;i != -1;i = r[i],j = r[j])
{
l[i] = j;
if(r[i] == -1) back = i;
n = ++cnt;
}
n++;//测试点3的坑,有多余的节点。
// cout << head << " " << back << endl;
for(int i = 0,h = head,b = back;i < n;i ++)//h头指针,b尾指针
{
if(i % 2 == 0)
{
printf("%05d %d ",b,e[b]);
if(i == n - 1)puts("-1");
else printf("%05d\n",h);
b = l[b];
}
else
{
printf("%05d %d ",h,e[h]);
if(i == n - 1) puts("-1");
else printf("%05d\n",b);
h = r[h];
}
}
return 0;
}