python自动化管理和zabbix监控网络设备(无线AC控制瘦ap配置部分)

news2025/1/21 6:26:36

目录

前言

拓扑

一、AC-SW1

二、AC1

三、SW1-6


 

前言


具体原理和操作可以访问我的主页视频

白帽小丑的个人空间-白帽小丑个人主页-哔哩哔哩视频


拓扑


一、AC-SW1

sys
sysname AC-SW1
vlan batch 100 200 210 220 230 240 250


stp region-configuration 
region-name huawei
revision-level 1
instance 3 vlan 200 210 220
instance 4 vlan 230 240 250
instance 5 vlan 100
active region-configuration
q

interface gi0/0/1
port link-type trunk
port trunk allow-pass vlan all

interface gi0/0/2
port link-type trunk
port trunk allow-pass vlan all

interface gi0/0/3
port link-type trunk
port trunk allow-pass vlan all

二、AC1

sys
sysname AC1
vlan batch 100 200 210 220 230 240 250


stp region-configuration 
region-name huawei
revision-level 1
instance 3 vlan 200 210 220
instance 4 vlan 230 240 250
instance 5 vlan 100
active region-configuration
q


interface Vlanif 200
ip address 172.200.1.253 23


interface Vlanif 210
ip address 172.210.3.253 23


interface Vlanif 220
ip address 172.220.5.253 23


interface Vlanif 230
ip address 172.230.7.253 23


interface Vlanif 240
ip address 172.240.9.253 23


interface Vlanif 250
ip address 172.250.11.253 23


interface Vlanif 100
ip address 192.168.100.253 24

inter gi0/0/1
port link trun
port trun a vlan all
quit


wlan
ap auth-mode no-auth
quit
capwap source ip-address 192.168.100.253


wlan
ap-mac 00e0-fc21-40b0
ap-name RA1_AP

ap-mac 00e0-fc70-64c0
ap-name RA2_AP

ap-mac 00e0-fc37-3860
ap-name HL_AP

ap-mac 00e0-fcab-0a90
ap-name CF_AP

ap-mac 00e0-fc7f-5cc0
ap-name DI_AP

ap-mac 00e0-fc19-4ff0
ap-name ET_AP


wlan
ap-group name RA1
regulatory-domain-profile defualt
Y
ap-group name RA2
regulatory-domain-profile defualt
Y
ap-group name HL
regulatory-domain-profile defualt
Y
ap-group name CF
regulatory-domain-profile defualt
Y
ap-group name DI
regulatory-domain-profile defualt
Y
ap-group name ET
regulatory-domain-profile defualt
Y


ap-name RA1_AP
ap-group RA1
Y
quit

ap-name RA2_AP
ap-group RA2
Y
quit

ap-name HL_AP
ap-group HL
Y
quit

ap-name CF_AP
ap-group CF
Y
quit

ap-name DI_AP
ap-group DI
Y
quit

ap-name ET_AP
ap-group ET
Y
quit


#RA1调优
wlan
security-profile name RA1
security wpa2 psk pass-phrase Aa1bB2Cc3 aes
quit

wlan
ssid-profile name Room_Area1
ssid Room_Area1
quit

wlan
vap-profile name Room_Area1
security-profile RA1
ssid-profile Room_Area1
forward-mode tunnel
service-vlan vlan-id 200
quit

#开启4G和5G频段

wlan
ap-name RA1_AP
vap-profile Room_Area1 wlan 1 radio 0
vap-profile Room_Area1 wlan 1 radio 1

quit





wlan
security-profile name RA2_AP
security wpa2 psk pass-phrase De4FgH5iJ aes
quit

wlan
ssid-profile name Room_Area2
ssid Room_Area2
quit

wlan
vap-profile name Room_Area2
security-profile RA2
ssid-profile Room_Area2
forward-mode tunnel
service-vlan vlan-id 210
quit

开启4G和5G频段

wlan
ap-name RA2_AP
vap-profile Room_Area2 wlan 1 radio 0
vap-profile Room_Area2 wlan 1 radio 1

quit


HL_AP

wlan
security-profile name HL_AP
security wpa2 psk pass-phrase K6lLmNo7P aes
quit

wlan
ssid-profile name Hotel_Lobby
ssid Hotel_Lobby
quit

wlan
vap-profile name Hotel_Lobby
security-profile HL_AP
ssid-profile Hotel_Lobby
forward-mode tunnel
service-vlan vlan-id 220
quit

开启4G和5G频段


wlan
ap-name HL_AP
vap-profile Hotel_Lobby wlan 1 radio 0
vap-profile Hotel_Lobby wlan 1 radio 1

quit


流量限速,上行和下行限速为3M
traffic-profile name wlan-traffic-HL_AP
rate-limit client down 3000     
rate-limit client up 3000
vap-profile name HL_AP
traffic-profile wlan-traffic-HL_AP

禁止低速率
ap-name HL_AP
radio-2g-profile name 0
dot11bg basic-rate 6 9 
ap-name HL_AP
radio-5g-profile name 0
dot11a basic-rate 6 9 
q

CF_AP

wlan
security-profile name CF_AP
security wpa2 psk pass-phrase Qr8sT9uUv aes
quit

wlan
ssid-profile name Conference
ssid Conference
quit

wlan
vap-profile name Conference
security-profile CF_AP
ssid-profile Conference
forward-mode tunnel
service-vlan vlan-id 230
quit

开启4G和5G频段

wlan
ap-name CF_AP
vap-profile Conference wlan 1 radio 0
vap-profile Conference wlan 1 radio 1

quit


流量限速,上行和下行限速为3M
traffic-profile name wlan-traffic-CF_AP
rate-limit client down 3000     
rate-limit client up 3000
vap-profile name CF_AP
traffic-profile wlan-traffic-CF_AP

禁止低速率
ap-name CF_AP
radio-2g-profile name 0
dot11bg basic-rate 6 9 
ap-name CF_AP
radio-5g-profile name 0
dot11a basic-rate 6 9 

DI_AP
wlan
security-profile name DI_AP
security wpa2 psk pass-phrase Wx5Yz6A7B aes
quit

wlan
ssid-profile name Dining
ssid Dining
quit

wlan
vap-profile name Dining
security-profile DI_AP
ssid-profile Dining
forward-mode tunnel
service-vlan vlan-id 240
quit

开启4G和5G频段

wlan
ap-name DI_AP
vap-profile Dining wlan 1 radio 0
vap-profile Dining wlan 1 radio 1

quit


流量限速,上行和下行限速为3M
traffic-profile name wlan-traffic-DI_AP
rate-limit client down 3000     
rate-limit client up 3000
vap-profile name DI_AP
traffic-profile wlan-traffic-DI_AP

禁止低速率
ap-name DI_AP
radio-2g-profile name 0
dot11bg basic-rate 6 9 
ap-name DI_AP
radio-5g-profile name 0
dot11a basic-rate 6 9 
q

ET_AP
wlan
security-profile name ET_AP
security wpa2 psk pass-phrase Wx5Yz6A7B aes
quit

wlan
ssid-profile name Entertainment
ssid Entertainment
quit

wlan
vap-profile name Entertainment
security-profile ET_AP
ssid-profile Entertainment
forward-mode tunnel
service-vlan vlan-id 250
quit

开启4G和5G频段

wlan
ap-name ET_AP
vap-profile Entertainment wlan 1 radio 0
vap-profile Entertainment wlan 1 radio 1

quit


流量限速,上行和下行限速为3M
traffic-profile name wlan-traffic-ET_AP
rate-limit client down 3000     
rate-limit client up 3000
vap-profile name ET_AP
traffic-profile wlan-traffic-ET_AP

禁止低速率
ap-name ET_AP
radio-2g-profile name 0
dot11bg basic-rate 6 9 
ap-name ET_AP
radio-5g-profile name 0
dot11a basic-rate 6 9 
q

三、SW1-6

SW1

system-view
sysname SW1
vlan batch 10 100 200

  inter gi0/0/1
  port link-type trunk
  port trunk allow-pass vlan 10 100 200
  quit

  inter gi0/0/2
  port link-type trunk
  port trunk allow-pass vlan 10 100 200
  quit

  inter gi0/0/3
  port link-type access
  port default vlan 10
  quit


stp region-configuration 
region-name huawei
revision-level 1
instance 1 vlan 10 20 30
instance 2 vlan 40 50 60
instance 3 vlan 200 210 220
instance 4 vlan 230 240 250
instance 5 vlan 100
active region-configuration
q

vlan 200
interface g 0/0/4
port link-type trunk
port trunk allow vlan 100 200
port trunk pvid vlan 100
q

SW2

system-view
sysname SW2
vlan batch 20 100 210

  inter gi0/0/1
  port link-type trunk
  port trunk allow-pass vlan 20 100 210
  quit

  inter gi0/0/2
  port link-type trunk
  port trunk allow-pass vlan 20 100 210
  quit

  inter gi0/0/3
  port link-type access
  port default vlan 20
  quit

stp region-configuration 
region-name huawei
revision-level 1
instance 1 vlan 10 20 30
instance 2 vlan 40 50 60
instance 3 vlan 200 210 220
instance 4 vlan 230 240 250
instance 5 vlan 100
active region-configuration
q

interface g 0/0/4
port link-type trunk
port trunk allow vlan 100 210
port trunk pvid vlan 100
q

SW3

system-view
sysname SW3
vlan batch 30 100 220

  inter gi0/0/1
  port link-type trunk
  port trunk allow-pass vlan 30 100 220
  quit

  inter gi0/0/2
  port link-type trunk
  port trunk allow-pass vlan 30 100 220
  quit

  inter gi0/0/3
  port link-type access
  port default vlan 30
  quit

stp region-configuration 
region-name huawei
revision-level 1
instance 1 vlan 10 20 30
instance 2 vlan 40 50 60
instance 3 vlan 200 210 220
instance 4 vlan 230 240 250
instance 5 vlan 100
active region-configuration
q

interface g 0/0/4
port link-type trunk
port trunk allow vlan 100 220
port trunk pvid vlan 100
q

SW4

system-view
sysname SW4
vlan batch 40 100 230

  inter gi0/0/1
  port link-type trunk
  port trunk allow-pass vlan 40 100 230
  quit

  inter gi0/0/2
  port link-type trunk
  port trunk allow-pass vlan 40 100 230
  quit

  inter gi0/0/3
  port link-type access
  port default vlan 40
  quit

stp region-configuration 
region-name huawei
revision-level 1
instance 1 vlan 10 20 30
instance 2 vlan 40 50 60
instance 3 vlan 200 210 220
instance 4 vlan 230 240 250
instance 5 vlan 100
active region-configuration
q

interface g 0/0/4
port link-type trunk
port trunk allow vlan 100 230
port trunk pvid vlan 100
q

SW5

system-view
sysname SW5
vlan batch 50 100 240

  inter gi0/0/1
  port link-type trunk
  port trunk allow-pass vlan 50 100 240
  quit

  inter gi0/0/2
  port link-type trunk
  port trunk allow-pass vlan 50 100 240
  quit

  inter gi0/0/3
  port link-type access
  port default vlan 50
  quit

stp region-configuration 
region-name huawei
revision-level 1
instance 1 vlan 10 20 30
instance 2 vlan 40 50 60
instance 3 vlan 200 210 220
instance 4 vlan 230 240 250
instance 5 vlan 100
active region-configuration
q

interface g 0/0/4
port link-type trunk
port trunk allow vlan 100 240
port trunk pvid vlan 100
q

SW6

system-view
sysname SW6
vlan batch 60 100 250

  inter gi0/0/1
  port link-type trunk
  port trunk allow-pass vlan 60 100 250
  quit

  inter gi0/0/2
  port link-type trunk
  port trunk allow-pass vlan 60 100 250
  quit

  inter gi0/0/3
  port link-type access
  port default vlan 60
  quit

stp region-configuration 
region-name huawei
revision-level 1
instance 1 vlan 10 20 30
instance 2 vlan 40 50 60
instance 3 vlan 200 210 220
instance 4 vlan 230 240 250
instance 5 vlan 100
active region-configuration
q

interface g 0/0/4
port link-type trunk
port trunk allow vlan 100 250
port trunk pvid vlan 100
q

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.coloradmin.cn/o/1475123.html

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈,一经查实,立即删除!

相关文章

R语言数学建模(一)—— 基础知识

R语言数学建模(一)—— 基础知识 文章目录 R语言数学建模(一)—— 基础知识前言一、建模软件1.1 软件建模的基础1.2 模型的分类1.3 不同类型模型间的联系1.4 一些术语1.5 建模如何适应数据分析过程 二、Tidyverse基础2.1 tidyvers…

4. client-go 编程式交互

Kubernetes 系统使用 client-go 作为 Go 语言的官方编程式交互客户端库,提供对 Kubernetes API Server 服务的交互访问。Kubernetes 的源码中已经集成了 client-go 的源码,无须单独下载。client-go 源码路径为 vendor/k8s.io/client-go。 开发者经常使用…

详解Kotlin中run、with、let、also与apply的使用和区别

Kotlin作为一种现代、静态类型的编程语言,不仅提供了丰富的特性,还提供了极具表现力的函数:run, with, let, also, 和 apply。理解这些函数的不同之处对于编写高效、易于维护的代码至关重要。 函数对比表 函数对象引用返回值使用场景runthi…

带大家做一个,易上手的家常黄瓜炒肉片

我们先准备一个瘦肉 一条黄瓜 黄瓜切片备用 准备 四个左右干辣椒 一小点花椒 四五个八角 两瓣大蒜 大蒜去皮切片 猪肉切片 尽量切薄一点 起锅烧油 油烧热后 下肉翻炒 猪肉完全变色后 下肉 八角 花椒 干辣椒 一切翻炒两下 然后下黄瓜片 一起翻炒两下 然后 下入 一勺生…

国辰智企MES系统优化企业管理,让生产制造更高效

在制造业的舞台上,MES制造执行管理系统如同一位出色的导演,将生产过程中的各个场景巧妙地连接起来,演绎出一场场精彩的制造盛宴。让我们一同走进MES在制造业的具体应用场景,感受它带来的变革与创新。 在生产计划与调度的场景中&am…

一种新型的AlGaN/GaN HEMTs小信号建模与参数提取方法

来源:A new small-signal modeling and extraction methodin AlGaN/GaN HEMTs(SOLID-STATE ELECTRONICS 07年) 摘要 本文提出了一种新型的用于GaN HEMTs(氮化镓高电子迁移率晶体管)的小信号等效电路,包含2…

WEB服务器-Tomcat(黑马学习笔记)

简介 服务器概述 服务器硬件 ● 指的也是计算机,只不过服务器要比我们日常使用的计算机大很多。 服务器,也称伺服器。是提供计算服务的设备。由于服务器需要响应服务请求,并进行处理,因此一般来说服务器应具备承担服务并且保障…

while 语句及goto 语句以及用 goto 语句构成循环

1、while 语句用来实现“当型”循环结构。其一般形式如下: while(表达式)语句 当表达式为非0值时,执行while语句中的内嵌语句。其流程图见图6.1,其特点是先判断表达式,后执行语句. 图 6.1 图 6.2 例6.2 求 用传统流程图和N-S结构流程图表示算法,见图6.2(a)和图6…

什么是智能合约

前言:在介绍智能合约的前提下,需要先介绍一下区块链 一.什么是区块链 区块链实质上是一个去中心化、分布式的可进行交易的数据库或账本,具有下列典型特征: 去中心化:简单来说,在网络上一个或多个服务器瘫…

针对KZG承诺和高效laconic OT的extractable witness encryption

1. 引言 2024年以太坊基金会等成员论文 Extractable Witness Encryption for KZG Commitments and Efficient Laconic OT,开源代码实现见: https://github.com/rot256/research-we-kzg(Rust) 在该论文中,提供了一种…

【漏洞复现】大华智慧园区综合管理平台信息泄露漏洞

Nx01 产品简介 大华智慧园区综合管理平台是一款综合管理平台,具备园区运营、资源调配和智能服务等功能。该平台旨在协助优化园区资源分配,满足多元化的管理需求,同时通过提供智能服务,增强使用体验。 Nx02 漏洞描述 大华智慧园区…

WPF 使用DrawingContext绘图,指定忽略一个区域,比如绘制同心圆扣除内圆范围

WPF 使用DrawingContext绘图,指定忽略一个区域,比如绘制同心圆扣除内圆范围 using System; using System.Windows; using System.Windows.Media;public class MyDrawingVisual : DrawingVisual {public void DrawEllipseWithHole(){using (DrawingCont…

kafka学习笔记三

第二篇 外部系统集成 Flume、Spark、Flink、SpringBoot 这些组件都可以作为kafka的生产者和消费者,在企业中非常常见。 Flume官网:Welcome to Apache Flume — Apache Flume Flink:Apache Flink_百度百科 Spark:Apache Spark…

微服务Springcloud智慧工地APP源码 AI人工智能识别 支持多工地使用

目录 一、现状描述 二、行业难点 APP端功能 一、项目人员 二、视频监控 三、危大工程 四、绿色施工 五、安全隐患 AI智能识别 环境监测 实名制管理 智慧监测 智慧工地全套解决方案 一、现状描述 建筑工程建设具有明显的生产规模大宗性与生产场所固定性的特点。建…

Alist访问主页显示空白解决方法

文章目录 问题记录问题探索和解决网络方案问题探究脚本内容查看 最终解决教程 问题记录 访问Alist主页显示空白,按F12打开开发人员工具 ,选择控制台,报错如下 index.75e31196.js:20 Uncaught TypeError: Cannot assign to read only property __symbo…

科技论文编写思路

科技论文编写思路 1.基本框架2.课题可行性评估1.研究目标和意义2.研究方法和技术3.可行性和可操作性4.风险和不确定性5.经济性和资源投入6.成果预期和评估 3.写作思路4.利用AI读论文5.实验流程 1.基本框架 IntroductionRelated worksMethodExperiment and analysisDiscussionC…

关于电商API接口数据采集,您需要的了解更多!

关于数据采集 随着企业业务数字化转型的推进,非数字原生企业对数据的感知和获取提出了新的要求和挑战,原有信息化平台的数据输出和人工录入能力已经远远满足不了企业内部组织在数字化下的运作需求。企业需要构建数据感知能力,采用现代化手段…

SQLlabs46关

如果我们直接用列去排序 ?sortusername/password username: passward 可以看到顺序是不同的,当然第一列第二列第三列也可以,基本上都是这个原理,那怎么去实现注入呢,我们主要是通过rand()去实现一个盲注或者报错注入…

Day05:反弹SHELL不回显带外正反向连接防火墙出入站文件下载

目录 常规基本渗透命令 文件上传下载-解决无图形化&解决数据传输 反弹Shell命令-解决数据回显&解决数据通讯 防火墙绕过-正向连接&反向连接&内网服务器 防火墙组合数据不回显-ICMP带外查询Dnslog 思维导图 章节知识点: 应用架构:W…

浅谈 Linux 网络编程 - 网络字节序

文章目录 前言核心知识关于 小端法关于 大端法网络字节序的转换 函数 前言 在进行 socket 网络编程时,会用到字节流的转换函数、例如 inet_pton、htons 等,那么为什么要用到这些函数呢,本篇主要就是对这部分进行介绍。 核心知识 重点需要记…