[USACO1.5] [IOI1994]数字三角形 Number Triangles
题目描述
观察下面的数字金字塔。
写一个程序来查找从最高点到底部任意处结束的路径,使路径经过数字的和最大。每一步可以走到左下方的点也可以到达右下方的点。
在上面的样例中,从 7 → 3 → 8 → 7 → 5 7 \to 3 \to 8 \to 7 \to 5 7→3→8→7→5 的路径产生了最大权值。
输入格式
第一个行一个正整数 r r r ,表示行的数目。
后面每行为这个数字金字塔特定行包含的整数。
输出格式
单独的一行,包含那个可能得到的最大的和。
样例 #1
样例输入 #1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
样例输出 #1
30
提示
【数据范围】
对于
100
%
100\%
100% 的数据,
1
≤
r
≤
1000
1\le r \le 1000
1≤r≤1000,所有输入在
[
0
,
100
]
[0,100]
[0,100] 范围内。
代码
#include <stdio.h>
#include <stdlib.h>
int max(int a, int b); // 用于比较两个数的大小的函数
#define MAX 10000
int dp[MAX][MAX]; // 定义一个二维数组,用于存储金字塔和动态规划的状态
int main(int argc, char *argv[])
{
int r, i, j;
scanf("%d", &r);
for (i = 1; i <= r; i++)
{
for (j = 1; j <=i; j++)
{
scanf("%d", &dp[i][j]); // 读取该位置的值
}
}
for (i = r - 1; i >= 1; i--) // 从倒数第二行开始,逐行向上
{
for (j = 1; j <= i; j++)
{
// 选择下方或者右下方的较大值,然后加上当前位置的值
dp[i][j] += max(dp[i + 1][j], dp[i + 1][j + 1]);
}
}
printf("%d\n", dp[1][1]); // 输出顶部的值,即最大值
return 0;
}
int max(int a, int b) // 用于比较两个数的大小的函数
{
if (a > b)
{
return a;
}
else
{
return b;
}
}
[USACO11JAN] Profits S
题目描述
The cows have opened a new business, and Farmer John wants to see how well they are doing. The business has been running for N (1 <= N <= 100,000) days, and every day i the cows recorded their net profit P_i (-1,000 <= P_i <= 1,000).
Farmer John wants to find the largest total profit that the cows have made during any consecutive time period. (Note that a consecutive time period can range in length from one day through N days.) Help him by writing a program to calculate the largest sum of consecutive profits.
奶牛们开始了新的生意,它们的主人约翰想知道它们到底能做得多好。这笔生意已经做了N(1≤N≤100,000)天,每天奶牛们都会记录下这一天的利润Pi(-1,000≤Pi≤1,000)。
约翰想要找到奶牛们在连续的时间期间所获得的最大的总利润。(注:连续时间的周期长度范围从第一天到第N天)。
请你写一个计算最大利润的程序来帮助他。
输入格式
* Line 1: A single integer: N
* Lines 2…N+1: Line i+1 contains a single integer: P_i
输出格式
* Line 1: A single integer representing the value of the maximum sum of profits for any consecutive time period.
样例 #1
样例输入 #1
7
-3
4
9
-2
-5
8
-3
样例输出 #1
14
提示
The maximum sum is obtained by taking the sum from the second through the sixth number (4, 9, -2, -5, 8) => 14.
代码
#include <stdio.h>
#include <stdlib.h>
int max(int a, int b); // 比较两个数的大小的函数
#define MAXN 200000
int main(int argc, char *argv[])
{
int N, i, P[MAXN], max_P;
int dp[MAXN]; // 表示以第i天结束的最大连续子序列的和
scanf("%d", &N);
for (i = 1; i <= N; i++)
{
scanf("%d", &P[i]); // 每天的利润
}
dp[1] = P[1]; // 初始化dp[1]为第一天的利润
max_P = dp[1]; // 记录最大的利润
for (i = 2; i <= N; i++)
{
dp[i] = max(dp[i - 1] + P[i], P[i]); // 状态转移方程
max_P = max(max_P, dp[i]); // 更新最大利润
}
printf("%d", max_P);
return 0;
}
int max(int a, int b) // 比较两个数的大小的函数
{
if (a > b)
{
return a;
}
else
{
return b;
}
}