题目:
1231. 航班时间 - AcWing题库
输入样例:
3
17:48:19 21:57:24
11:05:18 15:14:23
17:21:07 00:31:46 (+1)
23:02:41 16:13:20 (+1)
10:19:19 20:41:24
22:19:04 16:41:09 (+1)
输出样例:
04:09:05
12:10:39
14:22:05
思路:
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int get_seconds(int h,int m,int s)
{
return h*3600+m*60+s;
}
int get_time()
{
string line;
getline(cin,line);
if(line.back()!=')')line+="(+0)";
int h1,m1,s1,h2,m2,s2,d;
/*c_str() 是std::string类的一个成员函数,
将line转换为C风格的字符串,以便与使用C风格字符串的函数进行交互*/
sscanf(line.c_str(),"%d:%d:%d %d:%d:%d (+%d)",&h1,&m1,&s1,&h2,&m2,&s2,&d);
//sscanf从字符串中读取,scanf从标志输入中读取
return get_seconds(h2,m2,s2)-get_seconds(h1,m1,s1)+d*24*3600;
}
int main()
{
int n;
cin>>n;
string line;
getline(cin,line);//消除上面cin留下的换行符
while(n--){
int time=(get_time()+get_time())/2;
int h=time/3600;
int m=time%3600/60;
int s=time%60;
printf("%02d:%02d:%02d\n",h,m,s);
}
}
补充:
"cin>>line" VS "getline(cin,line)"
cin输入时遇到空格会断开,而getline则是整行输入。
故需要整行输入时用getline。